aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivivehiclefunctions/climate_widget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ivivehiclefunctions/climate_widget/CMakeLists.txt')
-rw-r--r--examples/ivivehiclefunctions/climate_widget/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/examples/ivivehiclefunctions/climate_widget/CMakeLists.txt b/examples/ivivehiclefunctions/climate_widget/CMakeLists.txt
new file mode 100644
index 0000000..e7eb371
--- /dev/null
+++ b/examples/ivivehiclefunctions/climate_widget/CMakeLists.txt
@@ -0,0 +1,47 @@
+# Generated from climate_widget.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(climate_widget LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/ivivehiclefunctions/climate_widget")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS IviCore)
+
+qt_add_executable(climate_widget
+ main.cpp
+ mainwindow.cpp mainwindow.h mainwindow.ui
+)
+set_target_properties(climate_widget PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(climate_widget PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::IviCore
+ ivivehiclefunctions
+)
+
+if((QT_MAJOR_VERSION GREATER 4))
+ target_link_libraries(climate_widget PUBLIC
+ Qt::Widgets
+ )
+endif()
+
+install(TARGETS climate_widget
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)