aboutsummaryrefslogtreecommitdiffstats
path: root/src/ivicore/queryparser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ivicore/queryparser/CMakeLists.txt')
-rw-r--r--src/ivicore/queryparser/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/ivicore/queryparser/CMakeLists.txt b/src/ivicore/queryparser/CMakeLists.txt
new file mode 100644
index 0000000..08aaeed
--- /dev/null
+++ b/src/ivicore/queryparser/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Generated from queryparser.pro.
+
+#####################################################################
+## queryparser Binary:
+#####################################################################
+
+qt_add_executable(queryparser
+ GUI
+ SOURCES
+ main.cpp
+ qiviqueryterm.cpp qiviqueryterm.h qiviqueryterm_p.h
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 3:.:.:queryparser.pri:enable-qlalr:
+# QMAKE_EXTRA_COMPILERS = "flex" "qlalr"
+# flex.CONFIG = "no_link"
+# flex.commands = "flex" "-L" "--nounistd" "-o" "${QMAKE_FILE_OUT}" "${QMAKE_FILE_NAME}"
+# flex.dependency_type = "TYPE_C"
+# flex.input = "FLEX"
+# flex.output = "$$PWD/${QMAKE_FILE_BASE}_flex_p.h"
+# qlalr.CONFIG = "no_link"
+# qlalr.commands = "cd" "$$PWD;" "$$[QT_INSTALL_BINS]/qlalr" "--qt" "--no-debug" "--no-lines" "--verbose" "${QMAKE_FILE_NAME}"
+# qlalr.dependency_type = "TYPE_C"
+# qlalr.input = "QLALR"
+# qlalr.output = "$$PWD/${QMAKE_FILE_BASE}_p.h"
+
+qt_extend_target(queryparser CONDITION NOT enable-qlalr
+ SOURCES
+ qiviqueryparser_p.h
+ qiviqueryparser_flex_p.h
+)
+
+#### Keys ignored in scope 5:.:.:queryparser.pri:else:
+# OTHER_FILES = "$$FLEX" "$$QLALR"