aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noanno/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noanno/test/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noanno/test/CMakeLists.txt20
1 files changed, 11 insertions, 9 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noanno/test/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noanno/test/CMakeLists.txt
index 604d87c..7f3de43 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-noanno/test/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noanno/test/CMakeLists.txt
@@ -5,18 +5,20 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-qt_add_executable(tst_org-example-echo-noanno)
+file(TOUCH ${CMAKE_CURRENT_BINARY_DIR}/cmake_dummy.cpp)
+qt_add_test(tst_org-example-echo-noanno
+ SOURCES
+ ${CMAKE_CURRENT_BINARY_DIR}/cmake_dummy.cpp
+ PUBLIC_LIBRARIES
+ echo_noanno_frontend
+ Qt::Core
+ Qt::IviCore
+ Qt::Test
+)
+set_target_properties(tst_org-example-echo-noanno PROPERTIES RUNTIME_OUTPUT_DIRECTORY ../)
# IVI Generator:
qt6_ivigenerator(tst_org-example-echo-noanno
QFACE_SOURCES ../../../org.example.echo.noannotation.qface
QFACE_FORMAT test
)
-
-target_link_libraries(tst_org-example-echo-noanno PUBLIC
- echo_noanno_frontend
- Qt::Core
- Qt::Gui
- Qt::IviCore
- Qt::Test
-)