aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt36
1 files changed, 16 insertions, 20 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt
index 81c7410..8390845 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt
@@ -1,25 +1,21 @@
# Generated from backend_simulator.pro.
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#####################################################################
-## echo_noannotation_simulator Generic Library:
-#####################################################################
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-qt_add_cmake_library(echo_noannotation_simulator
- MODULE
- OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../qtivi"
- INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_BINARY_DIR}/../frontend
- PUBLIC_LIBRARIES
- # Remove: L${CMAKE_CURRENT_BINARY_DIR}/..
- Qt::Core
- Qt::Gui
- Qt::IviCore
-)
-qt_disable_warnings(echo_noannotation_simulator)
+qt_add_plugin(echo_noanno_simulator)
-#### Keys ignored in scope 1:.:.:backend_simulator.pro:<TRUE>:
-# QFACE_FORMAT = "backend_simulator"
-# QFACE_SOURCES = "../../../org.example.echo.noannotation.qface"
-# TEMPLATE = "lib"
+# IVI Generator:
+qt6_ivigenerator(echo_noanno_simulator
+ QFACE_SOURCES ../../../org.example.echo.noannotation.qface
+ QFACE_FORMAT backend_simulator
+)
-qt_autogen_tools_initial_setup(echo_noannotation_simulator)
+target_link_libraries(echo_noanno_simulator PUBLIC
+ echo_noanno_frontend
+ Qt::Core
+ Qt::Gui
+ Qt::IviCore
+)