aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/frontend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/frontend/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/frontend/CMakeLists.txt44
1 files changed, 21 insertions, 23 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/frontend/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/frontend/CMakeLists.txt
index 0175304..c0162a1 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/frontend/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/frontend/CMakeLists.txt
@@ -1,28 +1,26 @@
# Generated from frontend.pro.
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#####################################################################
-## echo_noannotation_frontend Generic Library:
-#####################################################################
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-qt_add_cmake_library(echo_noannotation_frontend
- OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
- DEFINES
- QT_BUILD_ORG_EXAMPLE_ECHO_LIB
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
- Qt::IviCore
- Qt::IviCorePrivate
- Qt::Qml
- Qt::Quick
-)
-
-#### Keys ignored in scope 1:.:.:frontend.pro:<TRUE>:
-# QFACE_SOURCES = "../../../org.example.echo.noannotation.qface"
-# TEMPLATE = "lib"
+add_library(echo_noanno_frontend)
-## Scopes:
-#####################################################################
+# IVI Generator:
+qt6_ivigenerator(echo_noanno_frontend
+ QFACE_SOURCES ../../../org.example.echo.noannotation.qface
+ QFACE_FORMAT frontend
+)
+target_include_directories(echo_noanno_frontend PUBLIC
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
-#### Keys ignored in scope 2:.:.:frontend.pro:MACOS:
-# QMAKE_SONAME_PREFIX = "@rpath"
+target_link_libraries(echo_noanno_frontend PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::IviCore
+ Qt::IviCorePrivate
+ Qt::Qml
+ Qt::Quick
+)