aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/qmlplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/qmlplugin/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/qmlplugin/CMakeLists.txt30
1 files changed, 13 insertions, 17 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/qmlplugin/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/qmlplugin/CMakeLists.txt
index fd709bb..0ec3488 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/qmlplugin/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/qmlplugin/CMakeLists.txt
@@ -1,22 +1,18 @@
# Generated from qmlplugin.pro.
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#####################################################################
-## qmlplugin Generic Library:
-#####################################################################
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-qt_add_cmake_library(qmlplugin
- MODULE
- INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_BINARY_DIR}/../frontend
- PUBLIC_LIBRARIES
- # Remove: L${CMAKE_CURRENT_BINARY_DIR}/..
- Qt::IviCore
- ivivehiclefunctions
+# IVI Generator:
+qt6_ivigenerator(echo_frontend_noanno_qmlplugin # special case
+ QFACE_SOURCES ../../../org.example.echo.noannotation.qface
+ QFACE_FORMAT qmlplugin
)
-#### Keys ignored in scope 1:.:.:qmlplugin.pro:<TRUE>:
-# QFACE_FORMAT = "qmlplugin"
-# QFACE_SOURCES = "../../../org.example.echo.noannotation.qface"
-# TEMPLATE = "lib"
-
-qt_autogen_tools_initial_setup(qmlplugin)
+target_link_libraries(echo_frontend_noanno_qmlplugin PRIVATE # special case
+ echo_noanno_frontend
+ Qt::IviCore
+ Qt::IviVehicleFunctions
+)