aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt32
1 files changed, 2 insertions, 30 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
index 4983874..e248ff3 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
@@ -1,25 +1,12 @@
# Generated from server_qtro_test.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(tst_org-example-echo-qtro LANGUAGES CXX)
-
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Test)
-find_package(Qt6 COMPONENTS IviCore)
-
qt_add_executable(tst_org-example-echo-qtro
+ SOURCES
contactsmodelservice.cpp contactsmodelservice.h
echoservice.cpp echoservice.h
echozonedservice.cpp echozonedservice.h
@@ -33,26 +20,11 @@ qt6_ivigenerator(tst_org-example-echo-qtro
QFACE_SOURCES ../../../org.example.echo.qface
QFACE_FORMAT server_qtro
)
-set_target_properties(tst_org-example-echo-qtro PROPERTIES
- WIN32_EXECUTABLE FALSE
- MACOSX_BUNDLE FALSE
-)
-target_include_directories(tst_org-example-echo-qtro PUBLIC
- ${CMAKE_CURRENT_BINARY_DIR}/../backend_qtro
- ${CMAKE_CURRENT_BINARY_DIR}/../frontend
-)
target_link_libraries(tst_org-example-echo-qtro PUBLIC
- # Remove: L${CMAKE_CURRENT_BINARY_DIR}/..
echo_qtro_frontend
Qt::Core
Qt::IviCore
Qt::Test
- iviremoteobjects_helper_private
-)
-
-install(TARGETS tst_org-example-echo-qtro
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+ Qt::IviRemoteObjectsHelper
)