aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt29
1 files changed, 14 insertions, 15 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
index e248ff3..2d990b2 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
@@ -5,26 +5,25 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-qt_add_executable(tst_org-example-echo-qtro
+qt_add_test(tst_org-example-echo-qtro
SOURCES
- contactsmodelservice.cpp contactsmodelservice.h
- echoservice.cpp echoservice.h
- echozonedservice.cpp echozonedservice.h
- main.cpp
- server.cpp server.h
- tst_echoqtro.cpp tst_echoqtro.h
+ contactsmodelservice.cpp contactsmodelservice.h
+ echoservice.cpp echoservice.h
+ echozonedservice.cpp echozonedservice.h
+ main.cpp
+ server.cpp server.h
+ tst_echoqtro.cpp tst_echoqtro.h
+ PUBLIC_LIBRARIES
+ echo_qtro_frontend
+ Qt::Core
+ Qt::IviCore
+ Qt::Test
+ Qt::IviRemoteObjectsHelper
)
+set_target_properties(tst_org-example-echo-qtro PROPERTIES RUNTIME_OUTPUT_DIRECTORY ../)
# IVI Generator:
qt6_ivigenerator(tst_org-example-echo-qtro
QFACE_SOURCES ../../../org.example.echo.qface
QFACE_FORMAT server_qtro
)
-
-target_link_libraries(tst_org-example-echo-qtro PUBLIC
- echo_qtro_frontend
- Qt::Core
- Qt::IviCore
- Qt::Test
- Qt::IviRemoteObjectsHelper
-)