aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/queryparser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/queryparser/CMakeLists.txt')
-rw-r--r--tests/auto/core/queryparser/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/auto/core/queryparser/CMakeLists.txt b/tests/auto/core/queryparser/CMakeLists.txt
new file mode 100644
index 0000000..a460632
--- /dev/null
+++ b/tests/auto/core/queryparser/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from queryparser.pro.
+
+#####################################################################
+## tst_queryparser Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ testdata/*)
+list(APPEND test_data ${test_data_glob})
+
+qt_add_test(tst_queryparser
+ SOURCES
+ tst_queryparser.cpp
+ DEFINES
+ SRCDIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/\\\"
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::IviCore
+ Qt::IviCorePrivate
+ Qt::Qml
+ TESTDATA ${test_data}
+)
+
+#### Keys ignored in scope 1:.:.:queryparser.pro:<TRUE>:
+# QMAKE_PROJECT_NAME = "$$TARGET"
+# TEMPLATE = "app"