summaryrefslogtreecommitdiffstats
path: root/src/location/CMakeLists.txt
diff options
context:
space:
mode:
authorLaszlo Agocs <laszlo.agocs@qt.io>2022-11-30 12:12:03 +0100
committerMatthias Rauter <matthias.rauter@qt.io>2023-02-08 09:28:10 +0100
commit34fccf47ecf8ab2db53b23013f4f402c175ce9de (patch)
tree48d3ad9eb9d7568e29f0877e8ed9d49da98b6ce1 /src/location/CMakeLists.txt
parentcd4db512ae08836f5fa1d746000052215cf70a9c (diff)
Implement all four map items with Shape
With a master switch in qdeclarativegeomapitembase_p.h, this is enabled by default. For now the old method is still available by just commenting out the define. The old path can be removed in follow-up patches; for now keeping both so one can compare and debug if further issues arise. Pick-to: 6.5 Change-Id: I01c44ee8a07d7d5f7eb018be33ac5d161ba90e2a Reviewed-by: Matthias Rauter <matthias.rauter@qt.io> Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/location/CMakeLists.txt')
-rw-r--r--src/location/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/location/CMakeLists.txt b/src/location/CMakeLists.txt
index e0eca263..dce71dfe 100644
--- a/src/location/CMakeLists.txt
+++ b/src/location/CMakeLists.txt
@@ -86,6 +86,7 @@ qt_internal_add_module(Location
Qt::Core
Qt::Positioning
Qt::PositioningQuick
+ Qt::QuickShapesPrivate
PRIVATE_MODULE_INTERFACE
Qt::CorePrivate
Qt::QuickPrivate