summaryrefslogtreecommitdiffstats
path: root/src/plugins/geoservices/osm/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2023-08-03 22:28:51 +0200
committerMarc Mutz <marc.mutz@qt.io>2023-08-04 15:03:20 +0200
commit0e5abf1bd4496cdb5d4611aa2c4013d8d30f2ce4 (patch)
tree6cbd6813d65f0768500e524b2510a1357a27a9e3 /src/plugins/geoservices/osm/CMakeLists.txt
parent290f6a7620e7866f97cf483d2b7bf14a345a14a2 (diff)
Mark the module as Q_FOREACH-free
Do it centrally, so the whole module is protected. Amends da870b829cc860ca394af836733dbcc002016061. Change-Id: Ief67bee7411205f41cdd14bc4c4439a293f2d3dd Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Ivan Solovev <ivan.solovev@qt.io>
Diffstat (limited to 'src/plugins/geoservices/osm/CMakeLists.txt')
-rw-r--r--src/plugins/geoservices/osm/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/plugins/geoservices/osm/CMakeLists.txt b/src/plugins/geoservices/osm/CMakeLists.txt
index c35f4480..1f7c9843 100644
--- a/src/plugins/geoservices/osm/CMakeLists.txt
+++ b/src/plugins/geoservices/osm/CMakeLists.txt
@@ -23,6 +23,4 @@ qt_internal_add_plugin(QGeoServiceProviderFactoryOsmPlugin
Qt::Network
Qt::LocationPrivate
Qt::PositioningPrivate
- DEFINES
- QT_NO_FOREACH
)