summaryrefslogtreecommitdiffstats
path: root/src/plugins/geoservices/osm/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2022-07-24 12:39:01 +0200
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2022-07-26 08:34:51 +0000
commitda870b829cc860ca394af836733dbcc002016061 (patch)
treef9e1dc0774f43b2f621eac7654ec139ab00ba285 /src/plugins/geoservices/osm/CMakeLists.txt
parent7c00aa7aa1476fc45adc5abf54185545ecc4c14e (diff)
Replace foreach with ranged for and set QT_NO_FOREACH
Make containers const where they obviously should be, iterate over references where it's clearly possible. Cherry-pick of 2c8c5dca44aba5612cc67b04dd3c7e5fc4919b19. Change-Id: Ie55a58873b48bbb60ac49790db612f85777e6ceb Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/plugins/geoservices/osm/CMakeLists.txt')
-rw-r--r--src/plugins/geoservices/osm/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/plugins/geoservices/osm/CMakeLists.txt b/src/plugins/geoservices/osm/CMakeLists.txt
index ad6811b5..4cc55042 100644
--- a/src/plugins/geoservices/osm/CMakeLists.txt
+++ b/src/plugins/geoservices/osm/CMakeLists.txt
@@ -22,6 +22,8 @@ qt_internal_add_plugin(QGeoServiceProviderFactoryOsmPlugin
Qt::Network
Qt::LocationPrivate
Qt::PositioningPrivate
+ DEFINES
+ QT_NO_FOREACH
)
qt_internal_extend_target(QGeoServiceProviderFactoryOsmPlugin