summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2022-04-21 09:24:33 +0200
committerLars Knoll <lars.knoll@qt.io>2022-05-11 08:23:46 +0200
commit82943943820848b437fbc99c405bbb5169e880e1 (patch)
tree65936ec950b526a2865365959a4111c70bb836ea /src/CMakeLists.txt
parent5f5b32f5b03c2c8a9dfc59cbc1fa82713eb6d259 (diff)
Add the Quick3D.SpatialAudio QML module
Also this has been developed outside of Qt Multimedia so far, but it makes sense to add it here. This does however introduce an optional dependency of this module to qt quick3d. Change-Id: I357505a5832976917414acc07ca0480a635af176 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2850cc074..88f1792b5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -10,6 +10,9 @@ endif()
if(TARGET Qt::Quick)
add_subdirectory(multimediaquick)
endif()
+if(TARGET Qt::Quick3D AND QT_FEATURE_spatialaudio)
+ add_subdirectory(multimediaquick3d)
+endif()
if(TARGET Qt::Widgets)
add_subdirectory(multimediawidgets)