summaryrefslogtreecommitdiffstats
path: root/src/multimedia/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2022-04-30 16:45:44 +0200
committerLars Knoll <lars.knoll@qt.io>2022-05-11 08:24:12 +0200
commit1ec09ede3d696409ec86ec4f78394d431d4ddd4c (patch)
treeddd5cfb0bb2ad74378daf0f4300585943ee2f060 /src/multimedia/CMakeLists.txt
parentc47994d8f815546f85d6e5e55cbdf1ee09c75b59 (diff)
Add support for rooms to the spatial audio engine
The new QSpatialAudioRoom class allows defining a room. If the listener is inside the room, the properties of that room will get enabled, giving us first order reflections and reverb. Multiple rooms can be defined and the engine will automatically update the room to be used when the listener position changes. If the listener is inside multiple rooms, the room with the smallest volume will get chosen. Updated the spatialaudio example to allow modifying some of the room properties for testing. Change-Id: I94ffe0a6b7e570c4ea77898e021d7fe042fb9b52 Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'src/multimedia/CMakeLists.txt')
-rw-r--r--src/multimedia/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/multimedia/CMakeLists.txt b/src/multimedia/CMakeLists.txt
index faa1cbd3f..a5bfa2605 100644
--- a/src/multimedia/CMakeLists.txt
+++ b/src/multimedia/CMakeLists.txt
@@ -95,11 +95,14 @@ qt_internal_extend_target(Multimedia CONDITION QT_FEATURE_spatialaudio
spatial/qambisonicdecoder.cpp spatial/qambisonicdecoder_p.h spatial/qambisonicdecoderdata_p.h
spatial/qspatialaudioengine.cpp spatial/qspatialaudioengine.h spatial/qspatialaudioengine_p.h
spatial/qspatialaudiolistener.cpp spatial/qspatialaudiolistener.h
+ spatial/qspatialaudioroom.cpp spatial/qspatialaudioroom.h spatial/qspatialaudioroom_p.h
spatial/qspatialaudiosoundsource.cpp spatial/qspatialaudiosoundsource.h spatial/qspatialaudiosoundsource_p.h
spatial/qspatialaudiostereosource.cpp spatial/qspatialaudiostereosource.h
INCLUDE_DIRECTORIES
"../3rdparty/resonance-audio/resonance_audio"
+ "../3rdparty/resonance-audio"
"../resonance-audio"
+ "../3rdparty/eigen"
LIBRARIES
Qt::BundledResonanceAudio
)