summaryrefslogtreecommitdiffstats
path: root/src/multimedia/CMakeLists.txt
diff options
context:
space:
mode:
authorAhmad Samir <a.samirh78@gmail.com>2023-07-11 03:04:00 +0300
committerAhmad Samir <a.samirh78@gmail.com>2023-07-29 15:29:08 +0300
commit84bb3ea0039097c67bf104841fe8e1759f90c252 (patch)
treed328960c8632de48ef935d4fefc4af8d5e9546f5 /src/multimedia/CMakeLists.txt
parentafc196f36e0f88b3b1fa536377ebea02e471bf35 (diff)
Build with QT_NO_CONTEXTLESS_CONNECT
This disables the 3-arg QObject::connect() overload: QObject::connect(sender, signal, functor) For details see: https://lists.qt-project.org/pipermail/development/2023-July/044141.html Drive-by change: replace a std::bind with PMF, that is what the template arg "Method" is. Pick-to: 6.6 6.5 Change-Id: Id2b04febd3505dbdf2c1a950b86a277085d64376 Reviewed-by: Artem Dyomin <artem.dyomin@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/multimedia/CMakeLists.txt')
-rw-r--r--src/multimedia/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/multimedia/CMakeLists.txt b/src/multimedia/CMakeLists.txt
index 0190c6dbe..d1dc99a06 100644
--- a/src/multimedia/CMakeLists.txt
+++ b/src/multimedia/CMakeLists.txt
@@ -77,6 +77,8 @@ qt_internal_add_module(Multimedia
video/qvideoframeconverter.cpp video/qvideoframeconverter_p.h
video/qvideoframeformat.cpp video/qvideoframeformat.h
video/qvideowindow.cpp video/qvideowindow_p.h
+ DEFINES
+ QT_NO_CONTEXTLESS_CONNECT
INCLUDE_DIRECTORIES
audio
camera