summaryrefslogtreecommitdiffstats
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2022-01-10 09:31:48 +0100
committerLars Knoll <lars.knoll@qt.io>2022-01-11 15:16:12 +0100
commitccdc369cb82180bc12c3a6b00d33afad2848ba02 (patch)
treec22dd3e705c4bffe9b91aa0ddcd9e2edec3b752b /src/plugins/CMakeLists.txt
parent92f526ca472ba206883a8bbfd201469d52a1f1fc (diff)
Reintroduce a plugin architecture for multimedia backends
This is required, so we can introduce FFMpeg as a technology preview, and have both backends available in one compiled version of Qt. The plugin archicture is much simpler than in Qt 5, using one plugin per backend, not multiple. Export a couple of classes and methods from Qt Multimedia that are required for the backends to work. Change-Id: I99ab324c5ee018a3cefcf32d82f16a0bf6b5d409 Reviewed-by: Piotr Srebrny <piotr.srebrny@qt.io> Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index 73bcbf963..138e4c14b 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -1,5 +1 @@
-# Generated from plugins.pro.
-
-if(TARGET Qt::Quick)
- add_subdirectory(videonode)
-endif()
+#add_subdirectory(multimedia)