summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/multimedia/CMakeLists.txt')
-rw-r--r--examples/multimedia/CMakeLists.txt19
1 files changed, 11 insertions, 8 deletions
diff --git a/examples/multimedia/CMakeLists.txt b/examples/multimedia/CMakeLists.txt
index 44b701120..07bf4debd 100644
--- a/examples/multimedia/CMakeLists.txt
+++ b/examples/multimedia/CMakeLists.txt
@@ -1,16 +1,19 @@
-qt_internal_add_example(audiodecoder)
-if(NOT ANDROID AND NOT IOS)
- qt_internal_add_example(devices)
-endif()
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
if(TARGET Qt::Widgets)
- qt_internal_add_example(spectrum)
- qt_internal_add_example(audiorecorder)
if(NOT ANDROID AND NOT IOS)
qt_internal_add_example(audiodevices)
endif()
- qt_internal_add_example(audiosource)
qt_internal_add_example(audiooutput)
- qt_internal_add_example(spatialaudio)
+ qt_internal_add_example(audiorecorder)
+ qt_internal_add_example(audiosource)
+ qt_internal_add_example(camera)
+ qt_internal_add_example(player)
+ qt_internal_add_example(spectrum)
+ qt_internal_add_example(videographicsitem)
+ qt_internal_add_example(videowidget)
+ qt_internal_add_example(screencapture)
endif()
if(TARGET Qt::Quick)
qt_internal_add_example(declarative-camera)