summaryrefslogtreecommitdiffstats
path: root/examples/multimedia/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/multimedia/CMakeLists.txt')
-rw-r--r--examples/multimedia/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/multimedia/CMakeLists.txt b/examples/multimedia/CMakeLists.txt
new file mode 100644
index 000000000..07bf4debd
--- /dev/null
+++ b/examples/multimedia/CMakeLists.txt
@@ -0,0 +1,21 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+if(TARGET Qt::Widgets)
+ if(NOT ANDROID AND NOT IOS)
+ qt_internal_add_example(audiodevices)
+ endif()
+ qt_internal_add_example(audiooutput)
+ qt_internal_add_example(audiorecorder)
+ qt_internal_add_example(audiosource)
+ qt_internal_add_example(camera)
+ qt_internal_add_example(player)
+ qt_internal_add_example(spectrum)
+ qt_internal_add_example(videographicsitem)
+ qt_internal_add_example(videowidget)
+ qt_internal_add_example(screencapture)
+endif()
+if(TARGET Qt::Quick)
+ qt_internal_add_example(declarative-camera)
+ add_subdirectory(video)
+endif()