summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 62b88dcc1..6e556ff93 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -1,24 +1,26 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
cmake_minimum_required(VERSION 3.16)
-
-project(qmake_cmake_files)
+project(qtmultimedia_cmake_tests)
enable_testing()
-find_package(Qt5Core REQUIRED)
+find_package(Qt6 REQUIRED COMPONENTS Core)
+find_package(Qt6 OPTIONAL_COMPONENTS Widgets)
-include("${_Qt5CTestMacros}")
+include("${_Qt6CTestMacros}")
set(qt_module_includes
Multimedia QCamera
)
-if (NOT NO_WIDGETS)
+if(TARGET Qt6::Widgets)
list(APPEND qt_module_includes
MultimediaWidgets QVideoWidget
)
endif()
-test_module_includes(
+_qt_internal_test_module_includes(
${qt_module_includes}
)