summaryrefslogtreecommitdiffstats
path: root/tests/auto/integration/qaudiodecoderbackend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/integration/qaudiodecoderbackend/CMakeLists.txt')
-rw-r--r--tests/auto/integration/qaudiodecoderbackend/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/auto/integration/qaudiodecoderbackend/CMakeLists.txt b/tests/auto/integration/qaudiodecoderbackend/CMakeLists.txt
new file mode 100644
index 000000000..0133c7498
--- /dev/null
+++ b/tests/auto/integration/qaudiodecoderbackend/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# Generated from qaudiodecoderbackend.pro.
+
+#####################################################################
+## tst_qaudiodecoderbackend Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ testdata/*)
+list(APPEND test_data ${test_data_glob})
+
+qt_internal_add_test(tst_qaudiodecoderbackend
+ SOURCES
+ tst_qaudiodecoderbackend.cpp
+ ../shared/mediafileselector.h
+ ../shared/mediabackendutils.h
+ INCLUDE_DIRECTORIES
+ ../shared/
+ ../../../../src/multimedia/audio
+ LIBRARIES
+ Qt::Gui
+ Qt::Multimedia
+ Qt::MultimediaPrivate
+ TESTDATA ${test_data}
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(tst_qaudiodecoderbackend CONDITION boot2qt
+ DEFINES
+ WAV_SUPPORT_NOT_FORCED
+)