summaryrefslogtreecommitdiffstats
path: root/tests/auto/integration/qcamerabackend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/integration/qcamerabackend/CMakeLists.txt')
-rw-r--r--tests/auto/integration/qcamerabackend/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/auto/integration/qcamerabackend/CMakeLists.txt b/tests/auto/integration/qcamerabackend/CMakeLists.txt
index c89456e8a..07a6a4cae 100644
--- a/tests/auto/integration/qcamerabackend/CMakeLists.txt
+++ b/tests/auto/integration/qcamerabackend/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from qcamerabackend.pro.
#####################################################################
@@ -7,14 +10,17 @@
qt_internal_add_test(tst_qcamerabackend
SOURCES
tst_qcamerabackend.cpp
- PUBLIC_LIBRARIES
+ ../shared/mediabackendutils.h
+ INCLUDE_DIRECTORIES
+ ../shared/
+ LIBRARIES
Qt::Gui
Qt::MultimediaPrivate
Qt::Widgets
)
# special case begin
-if (APPLE)
+if(APPLE)
set_property(TARGET tst_qcamerabackend PROPERTY MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info.plist")
set_property(TARGET tst_qcamerabackend PROPERTY PROPERTY MACOSX_BUNDLE TRUE)
endif()