summaryrefslogtreecommitdiffstats
path: root/tests/auto/integration/qcamerabackend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/integration/qcamerabackend/CMakeLists.txt')
-rw-r--r--tests/auto/integration/qcamerabackend/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/auto/integration/qcamerabackend/CMakeLists.txt b/tests/auto/integration/qcamerabackend/CMakeLists.txt
new file mode 100644
index 000000000..07a6a4cae
--- /dev/null
+++ b/tests/auto/integration/qcamerabackend/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# Generated from qcamerabackend.pro.
+
+#####################################################################
+## tst_qcamerabackend Test:
+#####################################################################
+
+qt_internal_add_test(tst_qcamerabackend
+ SOURCES
+ tst_qcamerabackend.cpp
+ ../shared/mediabackendutils.h
+ INCLUDE_DIRECTORIES
+ ../shared/
+ LIBRARIES
+ Qt::Gui
+ Qt::MultimediaPrivate
+ Qt::Widgets
+)
+
+# special case begin
+if(APPLE)
+ set_property(TARGET tst_qcamerabackend PROPERTY MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info.plist")
+ set_property(TARGET tst_qcamerabackend PROPERTY PROPERTY MACOSX_BUNDLE TRUE)
+endif()
+# special case end