summaryrefslogtreecommitdiffstats
path: root/tests/auto/integration/qvideoframebackend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/integration/qvideoframebackend/CMakeLists.txt')
-rw-r--r--tests/auto/integration/qvideoframebackend/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/auto/integration/qvideoframebackend/CMakeLists.txt b/tests/auto/integration/qvideoframebackend/CMakeLists.txt
new file mode 100644
index 000000000..8c129fa97
--- /dev/null
+++ b/tests/auto/integration/qvideoframebackend/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Copyright (C) 2024 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## tst_qvideoframebackend Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ testdata/*)
+list(APPEND testdata_resource_files ${test_data_glob})
+
+qt_internal_add_test(tst_qvideoframebackend
+ SOURCES
+ ../shared/mediafileselector.h
+ ../shared/testvideosink.h
+ tst_qvideoframebackend.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::MultimediaPrivate
+ TESTDATA ${testdata_resource_files}
+ INCLUDE_DIRECTORIES
+ ../shared/
+)
+
+qt_internal_add_resource(tst_qvideoframebackend "testdata"
+ PREFIX
+ "/"
+ FILES
+ ${testdata_resource_files}
+)