summaryrefslogtreecommitdiffstats
path: root/tests/auto/unit/multimedia/qmediaplayer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/unit/multimedia/qmediaplayer/CMakeLists.txt')
-rw-r--r--tests/auto/unit/multimedia/qmediaplayer/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/auto/unit/multimedia/qmediaplayer/CMakeLists.txt b/tests/auto/unit/multimedia/qmediaplayer/CMakeLists.txt
new file mode 100644
index 000000000..4d3f2f865
--- /dev/null
+++ b/tests/auto/unit/multimedia/qmediaplayer/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# Generated from qmediaplayer.pro.
+
+#####################################################################
+## tst_qmediaplayer Test:
+#####################################################################
+
+qt_internal_add_test(tst_qmediaplayer
+ SOURCES
+ tst_qmediaplayer.cpp
+ INCLUDE_DIRECTORIES
+ ../../mockbackend
+ LIBRARIES
+ # Remove: L${CMAKE_CURRENT_SOURCE_DIR}
+ Qt::Gui
+ Qt::MultimediaPrivate
+ Qt::Network
+ MockMultimediaPlugin
+)
+
+# Resources:
+set(testdata_resource_files
+ "testdata/nokia-tune.mp3"
+)
+
+qt_internal_add_resource(tst_qmediaplayer "testdata"
+ PREFIX
+ "/"
+ FILES
+ ${testdata_resource_files}
+)
+