summaryrefslogtreecommitdiffstats
path: root/tests/manual/devices/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/devices/CMakeLists.txt')
-rw-r--r--tests/manual/devices/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/manual/devices/CMakeLists.txt b/tests/manual/devices/CMakeLists.txt
new file mode 100644
index 000000000..cae0c577f
--- /dev/null
+++ b/tests/manual/devices/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(devices LANGUAGES CXX)
+
+if(ANDROID OR IOS)
+ message(FATAL_ERROR "This is a commandline tool that is not supported on mobile platforms")
+endif()
+
+set(CMAKE_AUTOMOC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/multimedia/devices")
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Multimedia)
+
+qt_add_executable(devices
+ main.cpp
+)
+
+set_target_properties(devices PROPERTIES
+ WIN32_EXECUTABLE FALSE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(devices PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Multimedia
+)
+
+install(TARGETS devices
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)