summaryrefslogtreecommitdiffstats
path: root/examples/opcua/waterpump/simulationserver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/opcua/waterpump/simulationserver/CMakeLists.txt')
-rw-r--r--examples/opcua/waterpump/simulationserver/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/opcua/waterpump/simulationserver/CMakeLists.txt b/examples/opcua/waterpump/simulationserver/CMakeLists.txt
index 8befc71..67419c0 100644
--- a/examples/opcua/waterpump/simulationserver/CMakeLists.txt
+++ b/examples/opcua/waterpump/simulationserver/CMakeLists.txt
@@ -14,9 +14,10 @@ find_package(Qt6 REQUIRED COMPONENTS Core OpcUa)
qt_standard_project_setup()
-if (EXISTS ../../../../../../../${QT_REPO_MODULE_VERSION}/Automation/sources/qtopcua/)
- set(MODULE_SOURCE ../../../../../../../${QT_REPO_MODULE_VERSION}/Automation/sources/qtopcua/)
+if (EXISTS ../../../../../${Qt6_VERSION}/Src/qtopcua/)
+ set(MODULE_SOURCE ../../../../../${Qt6_VERSION}/Src/qtopcua/)
else()
+ # Build from source tree
set(MODULE_SOURCE ../../../../)
endif()