aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick3d/particles3d/CMakeLists.txt
diff options
context:
space:
mode:
authorKaj Grönholm <kaj.gronholm@qt.io>2021-11-19 11:30:15 +0200
committerKaj Grönholm <kaj.gronholm@qt.io>2021-12-02 16:56:42 +0200
commit3a08707e13abb847bc3948c9425b737b5f261496 (patch)
treeff07c36d6bda2052071e6a003b11b9d95b1c8574 /examples/quick3d/particles3d/CMakeLists.txt
parent23da179b3042bdd21caad5b608f2870b3e488df1 (diff)
Support lights with sprite particles
Add support for lights with the sprite particles. Add API to define all lights which particle should use. By default this is empty, so default behavior remains the same (lights not affecting the particles). Lights are only calculated on vertex shaders, for performance reasons and because particles are usually small in size. Lights have own shader feature levels to not affect the performance of non-lighted particles. Includes an example and lancelot tests. Task-number: QTBUG-90797 Change-Id: Idca84f6ec73e36d483c0598a9c08a54cec238afa Reviewed-by: Andy Nichols <andy.nichols@qt.io> Reviewed-by: Antti Määttä <antti.maatta@qt.io>
Diffstat (limited to 'examples/quick3d/particles3d/CMakeLists.txt')
-rw-r--r--examples/quick3d/particles3d/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/quick3d/particles3d/CMakeLists.txt b/examples/quick3d/particles3d/CMakeLists.txt
index 4b03394a..632e218a 100644
--- a/examples/quick3d/particles3d/CMakeLists.txt
+++ b/examples/quick3d/particles3d/CMakeLists.txt
@@ -52,6 +52,7 @@ qt_add_qml_module(particles3d
qml/FadingInOut.qml
qml/Fire.qml
qml/HeartTrail.qml
+ qml/Lights.qml
qml/LoggingView.qml
qml/ModelBlendParticles.qml
qml/OceanSpider.qml