aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick3d/particles3d/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-02-14 19:06:12 +0100
committerKai Köhne <kai.koehne@qt.io>2022-02-21 10:24:37 +0100
commit8316c111ae7b45050c256a5d2336a1cfd7c7493d (patch)
tree3e7a8576f92412406eb1ef8606f23fc266b33c4b /examples/quick3d/particles3d/CMakeLists.txt
parent64c9f1d6158aaa487d0fe2fbeaed5dc40fb4410d (diff)
Improve examples CMakeLists.txt
- Remove "# generated from xyz.pro" comment from pro2cmake - Remove automatic use of CMAKE_AUTORCC - Only opt into CMAKE_AUTOUIC if .ui files are involved - Remove explicit setting of CMAKE_INCLUDE_CURRENT_DIR - Combine multiple find_package(Qt6 ... calls) - use REQUIRED COMPONENTS - sort components alphabetically - Fix wrong indentations - Use (only) one empty line after multi-line commands Pick-to: 6.3 Change-Id: I8590d4bf781a8258cb9f3b11029a4d6c1a336dc0 Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/quick3d/particles3d/CMakeLists.txt')
-rw-r--r--examples/quick3d/particles3d/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/examples/quick3d/particles3d/CMakeLists.txt b/examples/quick3d/particles3d/CMakeLists.txt
index 93fc980b..3c683ea5 100644
--- a/examples/quick3d/particles3d/CMakeLists.txt
+++ b/examples/quick3d/particles3d/CMakeLists.txt
@@ -1,32 +1,25 @@
-# Generated from particles3d.pro.
-
cmake_minimum_required(VERSION 3.16)
project(particles3d LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick3d/particles3d")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS Quick3D)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Quick Quick3D)
qt_add_executable(particles3d
main.cpp
)
+
set_target_properties(particles3d PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(particles3d PUBLIC
Qt::Core
Qt::Gui