aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick3d/particles3d/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Nichols <andy.nichols@qt.io>2023-06-08 16:25:47 +0200
committerAndy Nichols <nezticle@gmail.com>2023-06-12 16:05:36 +0200
commitf7cc7656e2bd01851c5fb04747b0c8439ffa9dbe (patch)
tree3999f4a6efc61e1841e21941fd6bf8a51025d121 /examples/quick3d/particles3d/CMakeLists.txt
parent16c734c0a26b5fed0542f3ef2fee07be74a45da8 (diff)
Fix qmllint errors in particles3d example
Pick-to: 6.6 Change-Id: I10126755f2a42fb365219f09b9c54e45ed8e4316 Reviewed-by: Christian Strømme <christian.stromme@qt.io>
Diffstat (limited to 'examples/quick3d/particles3d/CMakeLists.txt')
-rw-r--r--examples/quick3d/particles3d/CMakeLists.txt135
1 files changed, 70 insertions, 65 deletions
diff --git a/examples/quick3d/particles3d/CMakeLists.txt b/examples/quick3d/particles3d/CMakeLists.txt
index d3caf5b7..e9f93845 100644
--- a/examples/quick3d/particles3d/CMakeLists.txt
+++ b/examples/quick3d/particles3d/CMakeLists.txt
@@ -30,76 +30,81 @@ target_link_libraries(particles3d PUBLIC
Qt::Quick3D
)
+set_source_files_properties(AppSettings.qml PROPERTIES
+ QT_QML_SINGLETON_TYPE TRUE
+)
+
qt_add_qml_module(particles3d
URI Example
VERSION 1.0
QML_FILES
- qml/AlignedParticles.qml
- qml/AnimatedSprite.qml
- qml/AttractorShapes.qml
- qml/ColorfulParticles.qml
- qml/CustomCheckBox.qml
- qml/CustomLabel.qml
- qml/CustomSlider.qml
- qml/CustomSelectionBox.qml
- qml/DynamicBursts.qml
- qml/EmitAndBurst.qml
- qml/EmitterCustomShapes.qml
- qml/EmitterShapes.qml
- qml/FadingInOut.qml
- qml/Fire.qml
- qml/HeartTrail.qml
- qml/Lights.qml
- qml/LoggingView.qml
- qml/ModelBlendParticles.qml
- qml/OceanSpider.qml
- qml/QtLogoAnimation.qml
- qml/SettingsView.qml
- qml/Snowing.qml
- qml/Sorting.qml
- qml/Speedometer.qml
- qml/StartupView.qml
- qml/SystemPlayPause.qml
- qml/TrailEmitterBurst.qml
- qml/ModelShape.qml
- qml/main.qml
- qml/LineParticles.qml
+ AlignedParticles.qml
+ AnimatedSprite.qml
+ AttractorShapes.qml
+ ColorfulParticles.qml
+ CustomCheckBox.qml
+ CustomLabel.qml
+ CustomSlider.qml
+ CustomSelectionBox.qml
+ DynamicBursts.qml
+ EmitAndBurst.qml
+ EmitterCustomShapes.qml
+ EmitterShapes.qml
+ FadingInOut.qml
+ Fire.qml
+ HeartTrail.qml
+ Lights.qml
+ LoggingView.qml
+ ModelBlendParticles.qml
+ OceanSpider.qml
+ QtLogoAnimation.qml
+ SettingsView.qml
+ Snowing.qml
+ Sorting.qml
+ Speedometer.qml
+ StartupView.qml
+ SystemPlayPause.qml
+ TrailEmitterBurst.qml
+ ModelShape.qml
+ main.qml
+ LineParticles.qml
+ AppSettings.qml
RESOURCES
- qml/images/arrow_icon.png
- qml/images/bear_black.png
- qml/images/colorTable.png
- qml/images/color_table2.png
- qml/images/color_table3.png
- qml/images/color_table4.png
- qml/images/color_table5.png
- qml/images/dot.png
- qml/images/dust.png
- qml/images/explosion_01_strip13.png
- qml/images/icon_interval.png
- qml/images/icon_logging.png
- qml/images/icon_pause.png
- qml/images/icon_play.png
- qml/images/icon_settings.png
- qml/images/leather_n.png
- qml/images/qt_logo.png
- qml/images/qt_logo2.png
- qml/images/qt_logo2_n.png
- qml/images/smoke.png
- qml/images/smoke_sprite.png
- qml/images/snowflake.png
- qml/images/speedometer_labels.png
- qml/images/sphere.png
- qml/images/sprite_09.png
- qml/images/star.png
- qml/images/star2.png
- qml/images/star3.png
- qml/meshes/meter_background.mesh
- qml/meshes/meter_edge.mesh
- qml/meshes/oldqtlogo.mesh
- qml/meshes/suzanne.mesh
- qml/data/qt_logo_in_4096.cbor
- qml/data/qt_logo_out_4096.cbor
- qml/data/heart_4096.cbor
+ images/arrow_icon.png
+ images/bear_black.png
+ images/colorTable.png
+ images/color_table2.png
+ images/color_table3.png
+ images/color_table4.png
+ images/color_table5.png
+ images/dot.png
+ images/dust.png
+ images/explosion_01_strip13.png
+ images/icon_interval.png
+ images/icon_logging.png
+ images/icon_pause.png
+ images/icon_play.png
+ images/icon_settings.png
+ images/leather_n.png
+ images/qt_logo.png
+ images/qt_logo2.png
+ images/qt_logo2_n.png
+ images/smoke.png
+ images/smoke_sprite.png
+ images/snowflake.png
+ images/speedometer_labels.png
+ images/sphere.png
+ images/sprite_09.png
+ images/star.png
+ images/star2.png
+ images/star3.png
+ meshes/meter_background.mesh
+ meshes/meter_edge.mesh
+ meshes/oldqtlogo.mesh
+ meshes/suzanne.mesh
+ data/qt_logo_in_4096.cbor
+ data/qt_logo_out_4096.cbor
+ data/heart_4096.cbor
NO_RESOURCE_TARGET_PATH
)