aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 18:27:59 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-15 12:22:59 +0000
commit5e6bf7e22eb3734aa711e9dd885bc5c594f7db4c (patch)
treefac78a35d68786be46b61b0c8d961f76bb0d4ab4 /CMakeLists.txt
parent6f617349cf865ca3a7befc0dd472b7c2510fc431 (diff)
Regenerate projects to be in sync
Change-Id: I3a57449c9025e22414b8337fcffdeb0f4d769af2 Reviewed-by: Liang Qi <liang.qi@qt.io> Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fdd80401..d9a9361f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,5 @@
+# Generated from qtquickcontrols2.pro.
+
cmake_minimum_required(VERSION 3.15.0)
project(QtQuickControls2
@@ -7,7 +9,11 @@ project(QtQuickControls2
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network Qml Quick QmlTools
- OPTIONAL_COMPONENTS QuickTest
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network Qml Quick QmlTools # special case
+ OPTIONAL_COMPONENTS QuickTest # special case
)
+if(NOT TARGET Qt::Quick)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Quick\" is not met.")
+ return()
+endif()
qt_build_repo()