aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-20 16:23:17 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-21 15:36:54 +0200
commit795c9831975aa2dca1586ed1b8f4c657ca066651 (patch)
tree34768785c45dd66297accc53afd1dc179bd5f87a /CMakeLists.txt
parenta5e1c787f6512013a092f7708c6928b5a9e263c2 (diff)
CMake: Fix no-widgets build
Task-number: QTBUG-86053 Change-Id: Ia2e3c3d0164550bb77b73edb3ef8f5e634e09ea7 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d6dbb0d6..1a2f4203 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,9 +15,8 @@ project(QtQuickControls2
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
# special case end
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network Qml Quick # special case
- OPTIONAL_COMPONENTS QuickTest # special case
-)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Network Qml Quick) # special case
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Widgets QuickTest) # special case
if(NOT TARGET Qt::Quick)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Quick\" is not met.")
return()