aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-18 14:23:21 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-22 21:12:26 +0200
commit9ed32b292fd5fd3a6f1909244bb5c3dd7cc7286b (patch)
tree0b3496cf7e9df232aecc1b624f142a100dcde031 /CMakeLists.txt
parent3198b43dbce2fac7baf56e451ae0a8b26e4243db (diff)
Use fixed qt_add_resource BASE argument
Pick-to: 6.1 Task-number: QTBUG-86726 Change-Id: Ie638443a76623df0ec20fbcd5485af59866deee6 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46cb3278..2798e5fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,9 @@ project(QtQuickControls2
# special case begin
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
+# Make sure we use the fixed BASE argument of qt_add_resource.
+set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
# special case end
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Qml) # special case