aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@qt.io>2021-05-31 16:40:54 +1000
committerUlf Hermann <ulf.hermann@qt.io>2021-06-05 12:52:00 +0200
commit5e8feb64d6a3cf50360c066e4595e41021bd0f9c (patch)
treec7901024f6c082dab14c97d109853ab5a64db1e1 /src/CMakeLists.txt
parent284936db8327f030473c0533041ee850f5369bdd (diff)
Update to latest qml CMake API
The new qml CMake API places a closer relationship between the backing target and the plugin target. Both are typically created together and they share a lot of common details. Instead of creating them in different parts of the source tree, they are now specified together. The src/imports area has effectively been absorbed into the other corresponding subdirectories below src with this change. Task-number: QTBUG-91621 Change-Id: I9bd32e9eb78c198ccc9db04e2829303cac323502 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9b11240b..deb79c7b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,7 +1,8 @@
# Generated from src.pro.
add_subdirectory(quicktemplates2)
-add_subdirectory(quickcontrols2)
add_subdirectory(quickcontrols2impl)
+add_subdirectory(quickcontrols2)
add_subdirectory(quickdialogs2)
-add_subdirectory(imports)
+add_subdirectory(quicknativestyle)
+add_subdirectory(labs)