aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/.prev_CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Curtis <mitch.curtis@qt.io>2020-03-27 11:17:35 +0100
committerMitch Curtis <mitch.curtis@qt.io>2020-08-26 11:45:57 +0200
commit5246dd2de211ffb81313a5c29ae7894545a28c43 (patch)
treeeedd1652642e519ccd8603612378eb5c0bfdca83 /src/imports/controls/.prev_CMakeLists.txt
parent9aafea810b8867fb31f9ec27a238628467e7ab56 (diff)
Register C++ types declaratively
Adapt to the new way of registering C++ types. The types need to be seen at compile time so that code can be generated that invokes them. This patch: - Adds QML_* macros where applicable. - Adapts the build system files to the new way of registering modules. - Splits up the QtQuick.Controls[.*].impl files into their own plugins, as we can only register one QML module per .pro file. - Removes C++ type registration calls in every plugin. - Moves private types from src/quickcontrols2/quickcontrols2.pro to src/quickcontrols2/impl/quickcontrols2-impl.pro. Some of these types need to be exposed to QML, but quickcontrols2.pro is already in use to declare the QtQuick.Controls import (and also provides the public C++ QQuickStyle API), and the new QML_IMPORT_NAME/VERSION syntax only allows one module per project. As some of the types that need to be exposed to QML are also referenced by some C++ code (e.g. tests, etc.), we just move all of the private types to the new library. Follow-up patches will register the QML types declaratively. Task-number: QTBUG-82922 Change-Id: Iaf9ee106237d61701d57a8896f3822304c8151a6 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/imports/controls/.prev_CMakeLists.txt')
-rw-r--r--src/imports/controls/.prev_CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/imports/controls/.prev_CMakeLists.txt b/src/imports/controls/.prev_CMakeLists.txt
index e017f0fe..a8f8da6b 100644
--- a/src/imports/controls/.prev_CMakeLists.txt
+++ b/src/imports/controls/.prev_CMakeLists.txt
@@ -5,7 +5,7 @@
#####################################################################
add_qml_module(qtquickcontrols2plugin
- TARGET_PATH "QtQuick/Controls.2"
+ TARGET_PATH "QtQuick/Controls"
URI "QtQuick.Controls"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
DESIGNER_SUPPORTED
@@ -63,7 +63,7 @@ set(qtquickcontrols2plugin_resource_files
add_qt_resource(qtquickcontrols2plugin "qtquickcontrols2plugin"
PREFIX
- "/qt-project.org/imports/QtQuick/Controls.2"
+ "/qt-project.org/imports/QtQuick/Controls"
FILES
${qtquickcontrols2plugin_resource_files}
)
@@ -72,7 +72,7 @@ add_qt_resource(qtquickcontrols2plugin "qtquickcontrols2plugin"
#### Keys ignored in scope 1:.:.:controls.pro:<TRUE>:
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES" "$$PWD/snippets/*.qml" "$$PWD/src/*.qdoc" "$$PWD/src/calendar/*.qdoc" "$$PWD/src/templates/*.qdoc"
-# TARGETPATH = "QtQuick/Controls.2"
+# TARGETPATH = "QtQuick/Controls"
# _REQUIREMENTS = "qtConfig(quickcontrols2-default)"
## Scopes: