aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/fusion/impl
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 12:34:56 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 22:23:40 +0200
commit22e3b6d2292ded526354569a1ffb342a660f1f80 (patch)
treeb99fe56e901b88e951022466bad6dc66feac359d /src/imports/controls/fusion/impl
parent85c5d6ad22948f0963dad97fe0ed504668992dc8 (diff)
CMake: Fix qml module version to use the repo project version
Use PROJECT_VERSION instead of CMAKE_PROJECT_VERSION, so that the repo project version is used in a top-level build, rather than the version of the qt5 project. Pick-to: 6.1 6.0 Task-number: QTBUG-92861 Change-Id: Ifd12d6309f358b9b72372a5c069141ecb7322bc7 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/imports/controls/fusion/impl')
-rw-r--r--src/imports/controls/fusion/impl/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/imports/controls/fusion/impl/CMakeLists.txt b/src/imports/controls/fusion/impl/CMakeLists.txt
index af5900bc..d80e69e8 100644
--- a/src/imports/controls/fusion/impl/CMakeLists.txt
+++ b/src/imports/controls/fusion/impl/CMakeLists.txt
@@ -6,7 +6,7 @@
qt_internal_add_qml_module(qtquickcontrols2fusionstyleimplplugin
URI "QtQuick.Controls.Fusion.impl"
- VERSION "${CMAKE_PROJECT_VERSION}"
+ VERSION "${PROJECT_VERSION}"
CLASSNAME QtQuickControls2FusionStyleImplPlugin
GENERATE_QMLTYPES
INSTALL_QMLTYPES