aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/fusion
diff options
context:
space:
mode:
authorMitch Curtis <mitch.curtis@qt.io>2020-08-11 11:57:24 +0200
committerMitch Curtis <mitch.curtis@qt.io>2020-08-26 11:46:11 +0200
commit80c5d0841e6f7c0c9aedfdc01b5d060ab2f66b7d (patch)
tree8de7772b63706db7408debf30c4e3f5ab9425b31 /src/imports/controls/fusion
parentb47e26d29db05ecf87f74815e37e0bf7394d06ba (diff)
Fix CMake build
Task-number: QTBUG-82922 Change-Id: I75f4a553a6bb260f77bfa791f12fa42e80131e09 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports/controls/fusion')
-rw-r--r--src/imports/controls/fusion/.prev_CMakeLists.txt172
-rw-r--r--src/imports/controls/fusion/CMakeLists.txt135
-rw-r--r--src/imports/controls/fusion/impl/CMakeLists.txt73
3 files changed, 281 insertions, 99 deletions
diff --git a/src/imports/controls/fusion/.prev_CMakeLists.txt b/src/imports/controls/fusion/.prev_CMakeLists.txt
index 4c59e4f6..b9d5e58b 100644
--- a/src/imports/controls/fusion/.prev_CMakeLists.txt
+++ b/src/imports/controls/fusion/.prev_CMakeLists.txt
@@ -4,18 +4,14 @@
## qtquickcontrols2fusionstyleplugin Plugin:
#####################################################################
-add_qml_module(qtquickcontrols2fusionstyleplugin
- TARGET_PATH "QtQuick/Controls/Fusion"
+qt_add_qml_module(qtquickcontrols2fusionstyleplugin
URI "QtQuick.Controls.Fusion"
- VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickControls2FusionStylePlugin
- DEPENDENCIES
- QtQuick.Controls/2.5
- SKIP_TYPE_REGISTRATION
+ IMPORTS
+ QtQuick.Controls.Default/auto
+ GENERATE_QMLTYPES
SOURCES
- qquickfusionbusyindicator.cpp qquickfusionbusyindicator_p.h
- qquickfusiondial.cpp qquickfusiondial_p.h
- qquickfusionknob.cpp qquickfusionknob_p.h
qquickfusionstyle.cpp qquickfusionstyle_p.h
qquickfusiontheme.cpp qquickfusiontheme_p.h
qtquickcontrols2fusionstyleplugin.cpp
@@ -52,7 +48,7 @@ set(qtquickcontrols2fusionstyle_resource_files
"images/progressmask@4x.png"
)
-add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
+qt_add_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
PREFIX
"/qt-project.org/imports/QtQuick/Controls/Fusion"
FILES
@@ -61,9 +57,9 @@ add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
#### Keys ignored in scope 1:.:.:fusion.pro:<TRUE>:
-# IMPORT_NAME = "QtQuick.Controls.Fusion"
-# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
+# QML_IMPORT_NAME = "QtQuick.Controls.Fusion"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
# TARGETPATH = "QtQuick/Controls/Fusion"
# _REQUIREMENTS = "qtConfig(quickcontrols2-fusion)"
@@ -71,10 +67,8 @@ set(qml_files
"ApplicationWindow.qml"
"BusyIndicator.qml"
"Button.qml"
- "ButtonPanel.qml"
"CheckBox.qml"
"CheckDelegate.qml"
- "CheckIndicator.qml"
"ComboBox.qml"
"DelayButton.qml"
"Dial.qml"
@@ -83,6 +77,7 @@ set(qml_files
"Drawer.qml"
"Frame.qml"
"GroupBox.qml"
+ "HorizontalHeaderView.qml"
"ItemDelegate.qml"
"Label.qml"
"Menu.qml"
@@ -97,19 +92,15 @@ set(qml_files
"ProgressBar.qml"
"RadioButton.qml"
"RadioDelegate.qml"
- "RadioIndicator.qml"
"RangeSlider.qml"
"RoundButton.qml"
"ScrollBar.qml"
"ScrollIndicator.qml"
"Slider.qml"
- "SliderGroove.qml"
- "SliderHandle.qml"
"SpinBox.qml"
"SplitView.qml"
"SwipeDelegate.qml"
"SwitchDelegate.qml"
- "SwitchIndicator.qml"
"Switch.qml"
"TabBar.qml"
"TabButton.qml"
@@ -120,6 +111,151 @@ set(qml_files
"ToolSeparator.qml"
"ToolTip.qml"
"Tumbler.qml"
+ "VerticalHeaderView.qml"
+)
+set_source_files_properties(ApplicationWindow.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(BusyIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Button.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(CheckBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(CheckDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ComboBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(DelayButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.2;6.0"
+)
+set_source_files_properties(Dial.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Dialog.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(DialogButtonBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(Drawer.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Frame.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(GroupBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(HorizontalHeaderView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.15;6.0"
+)
+set_source_files_properties(ItemDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Label.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Menu.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(MenuBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(MenuBarItem.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3;6.0"
+)
+set_source_files_properties(MenuItem.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(MenuSeparator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(Page.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(PageIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Pane.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Popup.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ProgressBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RadioButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RadioDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RangeSlider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(RoundButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(ScrollBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ScrollIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Slider.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SpinBox.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SplitView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.13;6.0"
+)
+set_source_files_properties(SwipeDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(SwitchDelegate.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Switch.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TabBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TabButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TextArea.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(TextField.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolBar.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolButton.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(ToolSeparator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.1;6.0"
+)
+set_source_files_properties(ToolTip.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(Tumbler.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
+set_source_files_properties(VerticalHeaderView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.15;6.0"
)
qt6_target_qml_files(qtquickcontrols2fusionstyleplugin
diff --git a/src/imports/controls/fusion/CMakeLists.txt b/src/imports/controls/fusion/CMakeLists.txt
index 5eb28d21..9d93aa89 100644
--- a/src/imports/controls/fusion/CMakeLists.txt
+++ b/src/imports/controls/fusion/CMakeLists.txt
@@ -7,15 +7,12 @@
qt_add_qml_module(qtquickcontrols2fusionstyleplugin
TARGET_PATH "QtQuick/Controls/Fusion"
URI "QtQuick.Controls.Fusion"
- VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ VERSION "6.0" # special case
CLASSNAME QtQuickControls2FusionStylePlugin
- DEPENDENCIES
- QtQuick.Controls/2.5
- SKIP_TYPE_REGISTRATION
+ IMPORTS
+ QtQuick.Controls.Default/auto
+ GENERATE_QMLTYPES
SOURCES
- qquickfusionbusyindicator.cpp qquickfusionbusyindicator_p.h
- qquickfusiondial.cpp qquickfusiondial_p.h
- qquickfusionknob.cpp qquickfusionknob_p.h
qquickfusionstyle.cpp qquickfusionstyle_p.h
qquickfusiontheme.cpp qquickfusiontheme_p.h
qtquickcontrols2fusionstyleplugin.cpp
@@ -61,9 +58,9 @@ qt_add_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
#### Keys ignored in scope 1:.:.:fusion.pro:<TRUE>:
-# IMPORT_NAME = "QtQuick.Controls.Fusion"
-# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
+# QML_IMPORT_NAME = "QtQuick.Controls.Fusion"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
# TARGETPATH = "QtQuick/Controls/Fusion"
# _REQUIREMENTS = "qtConfig(quickcontrols2-fusion)"
@@ -71,10 +68,8 @@ set(qml_files
"ApplicationWindow.qml"
"BusyIndicator.qml"
"Button.qml"
- "ButtonPanel.qml"
"CheckBox.qml"
"CheckDelegate.qml"
- "CheckIndicator.qml"
"ComboBox.qml"
"DelayButton.qml"
"Dial.qml"
@@ -98,19 +93,15 @@ set(qml_files
"ProgressBar.qml"
"RadioButton.qml"
"RadioDelegate.qml"
- "RadioIndicator.qml"
"RangeSlider.qml"
"RoundButton.qml"
"ScrollBar.qml"
"ScrollIndicator.qml"
"Slider.qml"
- "SliderGroove.qml"
- "SliderHandle.qml"
"SpinBox.qml"
"SplitView.qml"
"SwipeDelegate.qml"
"SwitchDelegate.qml"
- "SwitchIndicator.qml"
"Switch.qml"
"TabBar.qml"
"TabButton.qml"
@@ -124,166 +115,148 @@ set(qml_files
"VerticalHeaderView.qml"
)
set_source_files_properties(ApplicationWindow.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(BusyIndicator.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Button.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
-)
-set_source_files_properties(ButtonPanel.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(CheckBox.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(CheckDelegate.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
-)
-set_source_files_properties(CheckIndicator.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(ComboBox.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(DelayButton.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.2;6.0"
)
set_source_files_properties(Dial.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Dialog.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.1;6.0"
)
set_source_files_properties(DialogButtonBox.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.1;6.0"
)
set_source_files_properties(Drawer.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Frame.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(GroupBox.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(HorizontalHeaderView.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.15;6.0"
)
set_source_files_properties(ItemDelegate.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Label.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Menu.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(MenuBar.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.3;6.0"
)
set_source_files_properties(MenuBarItem.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.3;6.0"
)
set_source_files_properties(MenuItem.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(MenuSeparator.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.1;6.0"
)
set_source_files_properties(Page.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(PageIndicator.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Pane.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Popup.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(ProgressBar.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(RadioButton.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(RadioDelegate.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
-)
-set_source_files_properties(RadioIndicator.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(RangeSlider.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(RoundButton.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.1;6.0"
)
set_source_files_properties(ScrollBar.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(ScrollIndicator.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Slider.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
-)
-set_source_files_properties(SliderGroove.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
-)
-set_source_files_properties(SliderHandle.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(SpinBox.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(SplitView.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.13;6.0"
)
set_source_files_properties(SwipeDelegate.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(SwitchDelegate.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
-)
-set_source_files_properties(SwitchIndicator.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Switch.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(TabBar.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(TabButton.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(TextArea.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(TextField.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(ToolBar.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(ToolButton.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(ToolSeparator.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.1;6.0"
)
set_source_files_properties(ToolTip.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(Tumbler.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.0;6.0"
)
set_source_files_properties(VerticalHeaderView.qml PROPERTIES
- QT_QML_SKIP_QMLDIR_ENTRY TRUE
+ QT_QML_SOURCE_VERSION "2.15;6.0"
)
qt6_target_qml_files(qtquickcontrols2fusionstyleplugin
diff --git a/src/imports/controls/fusion/impl/CMakeLists.txt b/src/imports/controls/fusion/impl/CMakeLists.txt
new file mode 100644
index 00000000..628c5f90
--- /dev/null
+++ b/src/imports/controls/fusion/impl/CMakeLists.txt
@@ -0,0 +1,73 @@
+# Generated from fusion-impl.pro.
+
+#####################################################################
+## qtquickcontrols2fusionstyleimplplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qtquickcontrols2fusionstyleimplplugin
+ URI "QtQuick.Controls.Fusion.impl"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtQuickControls2FusionStyleImpPlugin
+ GENERATE_QMLTYPES
+ SOURCES
+ qquickfusionbusyindicator.cpp qquickfusionbusyindicator_p.h
+ qquickfusiondial.cpp qquickfusiondial_p.h
+ qquickfusionknob.cpp qquickfusionknob_p.h
+ qtquickcontrols2fusionstyleimplplugin.cpp
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::QmlPrivate
+ Qt::QuickControls2ImplPrivate
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+#### Keys ignored in scope 1:.:.:fusion-impl.pro:<TRUE>:
+# OTHER_FILES = "qmldir" "$$QML_FILES"
+# QML_FILES = "$$PWD/ButtonPanel.qml" "$$PWD/CheckIndicator.qml" "$$PWD/RadioIndicator.qml" "$$PWD/SliderGroove.qml" "$$PWD/SliderHandle.qml" "$$PWD/SwitchIndicator.qml"
+# QML_IMPORT_NAME = "QtQuick.Controls.Fusion.impl"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# QT_FOR_CONFIG = "quickcontrols2-private"
+# TARGETPATH = "QtQuick/Controls/Fusion/impl"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-fusion)"
+
+set(qml_files
+ "ButtonPanel.qml"
+ "CheckIndicator.qml"
+ "RadioIndicator.qml"
+ "SliderGroove.qml"
+ "SliderHandle.qml"
+ "SwitchIndicator.qml"
+)
+set_source_files_properties(ButtonPanel.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3"
+)
+set_source_files_properties(CheckIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3"
+)
+set_source_files_properties(RadioIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3"
+)
+set_source_files_properties(SliderGroove.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3"
+)
+set_source_files_properties(SliderHandle.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3"
+)
+set_source_files_properties(SwitchIndicator.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3"
+)
+
+qt6_target_qml_files(qtquickcontrols2fusionstyleimplplugin
+ FILES
+ ${qml_files}
+)