aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/imagine/.prev_CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-23 11:34:07 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-07 21:54:30 +0200
commited65d1ab49e6f5537b086178f9f9d14fc190b663 (patch)
treedca778ac347fb25b11bd665e0818f8454c7be0b1 /src/imports/controls/imagine/.prev_CMakeLists.txt
parent81e8cd67198768a08f5c65ec026e1553f78e1375 (diff)
CMake: Regenerate projects to use new qt_internal_ API
Modify special case locations to use the new API as well. Task-number: QTBUG-86815 Change-Id: I4a690095fcd4b1141550de86b6820ae2dd579429 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/imports/controls/imagine/.prev_CMakeLists.txt')
-rw-r--r--src/imports/controls/imagine/.prev_CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/imports/controls/imagine/.prev_CMakeLists.txt b/src/imports/controls/imagine/.prev_CMakeLists.txt
index 8d08bcca..832e87e6 100644
--- a/src/imports/controls/imagine/.prev_CMakeLists.txt
+++ b/src/imports/controls/imagine/.prev_CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2imaginestyleplugin Plugin:
#####################################################################
-qt_add_qml_module(qtquickcontrols2imaginestyleplugin
+qt_internal_add_qml_module(qtquickcontrols2imaginestyleplugin
URI "QtQuick.Controls.Imagine"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickControls2ImagineStylePlugin
@@ -49,7 +49,7 @@ set(qmake_qtquickcontrols2imaginestyle_resource_files
${resource_glob_1}
)
-qt_add_resource(qtquickcontrols2imaginestyleplugin "qmake_qtquickcontrols2imaginestyle"
+qt_internal_add_resource(qtquickcontrols2imaginestyleplugin "qmake_qtquickcontrols2imaginestyle"
PREFIX
"qt-project.org/imports/QtQuick/Controls/Imagine"
FILES
@@ -93,6 +93,7 @@ set(qml_files
"RadioDelegate.qml"
"RangeSlider.qml"
"RoundButton.qml"
+ "ScrollView.qml"
"ScrollBar.qml"
"ScrollIndicator.qml"
"Slider.qml"
@@ -198,6 +199,9 @@ set_source_files_properties(RangeSlider.qml PROPERTIES
set_source_files_properties(RoundButton.qml PROPERTIES
QT_QML_SOURCE_VERSION "2.1;6.0"
)
+set_source_files_properties(ScrollView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
set_source_files_properties(ScrollBar.qml PROPERTIES
QT_QML_SOURCE_VERSION "2.0;6.0"
)