aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 18:27:59 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-15 12:22:59 +0000
commit5e6bf7e22eb3734aa711e9dd885bc5c594f7db4c (patch)
treefac78a35d68786be46b61b0c8d961f76bb0d4ab4 /src/imports/controls
parent6f617349cf865ca3a7befc0dd472b7c2510fc431 (diff)
Regenerate projects to be in sync
Change-Id: I3a57449c9025e22414b8337fcffdeb0f4d769af2 Reviewed-by: Liang Qi <liang.qi@qt.io> Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/imports/controls')
-rw-r--r--src/imports/controls/.prev_CMakeLists.txt1
-rw-r--r--src/imports/controls/CMakeLists.txt9
-rw-r--r--src/imports/controls/fusion/.prev_CMakeLists.txt6
-rw-r--r--src/imports/controls/fusion/CMakeLists.txt5
-rw-r--r--src/imports/controls/imagine/.prev_CMakeLists.txt6
-rw-r--r--src/imports/controls/imagine/CMakeLists.txt5
-rw-r--r--src/imports/controls/material/.prev_CMakeLists.txt6
-rw-r--r--src/imports/controls/material/CMakeLists.txt5
-rw-r--r--src/imports/controls/universal/.prev_CMakeLists.txt6
-rw-r--r--src/imports/controls/universal/CMakeLists.txt5
10 files changed, 17 insertions, 37 deletions
diff --git a/src/imports/controls/.prev_CMakeLists.txt b/src/imports/controls/.prev_CMakeLists.txt
index 30d8a0b8..e017f0fe 100644
--- a/src/imports/controls/.prev_CMakeLists.txt
+++ b/src/imports/controls/.prev_CMakeLists.txt
@@ -73,7 +73,6 @@ add_qt_resource(qtquickcontrols2plugin "qtquickcontrols2plugin"
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES" "$$PWD/snippets/*.qml" "$$PWD/src/*.qdoc" "$$PWD/src/calendar/*.qdoc" "$$PWD/src/templates/*.qdoc"
# TARGETPATH = "QtQuick/Controls.2"
-# _LOADED = "qml_plugin"
# _REQUIREMENTS = "qtConfig(quickcontrols2-default)"
## Scopes:
diff --git a/src/imports/controls/CMakeLists.txt b/src/imports/controls/CMakeLists.txt
index abb531fc..ae0d1e60 100644
--- a/src/imports/controls/CMakeLists.txt
+++ b/src/imports/controls/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2plugin Plugin:
#####################################################################
-add_qml_module(qtquickcontrols2plugin
+qt_add_qml_module(qtquickcontrols2plugin
TARGET_PATH "QtQuick/Controls.2"
URI "QtQuick.Controls"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
@@ -61,7 +61,9 @@ set(qtquickcontrols2plugin_resource_files
"images/drop-indicator@4x.png"
)
-add_qt_resource(qtquickcontrols2plugin "qtquickcontrols2plugin"
+qt_add_resource(qtquickcontrols2plugin "qtquickcontrols2plugin"
+ PREFIX
+ "/qt-project.org/imports/QtQuick/Controls.2"
FILES
${qtquickcontrols2plugin_resource_files}
)
@@ -71,7 +73,6 @@ add_qt_resource(qtquickcontrols2plugin "qtquickcontrols2plugin"
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES" "$$PWD/snippets/*.qml" "$$PWD/src/*.qdoc" "$$PWD/src/calendar/*.qdoc" "$$PWD/src/templates/*.qdoc"
# TARGETPATH = "QtQuick/Controls.2"
-# _LOADED = "qml_plugin"
# _REQUIREMENTS = "qtConfig(quickcontrols2-default)"
## Scopes:
@@ -139,7 +140,7 @@ qt6_target_qml_files(qtquickcontrols2plugin
FILES
${qml_files}
)
-add_qt_docs(qtquickcontrols2plugin
+qt_add_docs(qtquickcontrols2plugin
doc/qtquickcontrols.qdocconf
)
diff --git a/src/imports/controls/fusion/.prev_CMakeLists.txt b/src/imports/controls/fusion/.prev_CMakeLists.txt
index f2b3cd5e..2fb5b2a1 100644
--- a/src/imports/controls/fusion/.prev_CMakeLists.txt
+++ b/src/imports/controls/fusion/.prev_CMakeLists.txt
@@ -65,7 +65,7 @@ add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
# TARGETPATH = "QtQuick/Controls.2/Fusion"
-# _LOADED = "qml_plugin"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-fusion)"
set(qml_files
"ApplicationWindow.qml"
@@ -122,10 +122,6 @@ set(qml_files
"Tumbler.qml"
)
-set_source_files_properties(${qml_files} PROPERTIES
- QT_QML_SOURCE_INSTALL TRUE
-)
-
qt6_target_qml_files(qtquickcontrols2fusionstyleplugin
FILES
${qml_files}
diff --git a/src/imports/controls/fusion/CMakeLists.txt b/src/imports/controls/fusion/CMakeLists.txt
index 581dc739..ee8f2c92 100644
--- a/src/imports/controls/fusion/CMakeLists.txt
+++ b/src/imports/controls/fusion/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2fusionstyleplugin Plugin:
#####################################################################
-add_qml_module(qtquickcontrols2fusionstyleplugin
+qt_add_qml_module(qtquickcontrols2fusionstyleplugin
TARGET_PATH "QtQuick/Controls.2/Fusion"
URI "QtQuick.Controls.Fusion"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
@@ -52,7 +52,7 @@ set(qtquickcontrols2fusionstyle_resource_files
"images/progressmask@4x.png"
)
-add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
+qt_add_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
PREFIX
"/qt-project.org/imports/QtQuick/Controls.2/Fusion"
FILES
@@ -65,7 +65,6 @@ add_qt_resource(qtquickcontrols2fusionstyleplugin "qtquickcontrols2fusionstyle"
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
# TARGETPATH = "QtQuick/Controls.2/Fusion"
-# _LOADED = "qml_plugin"
# _REQUIREMENTS = "qtConfig(quickcontrols2-fusion)"
set(qml_files
diff --git a/src/imports/controls/imagine/.prev_CMakeLists.txt b/src/imports/controls/imagine/.prev_CMakeLists.txt
index b2a50e05..5deb1489 100644
--- a/src/imports/controls/imagine/.prev_CMakeLists.txt
+++ b/src/imports/controls/imagine/.prev_CMakeLists.txt
@@ -65,7 +65,7 @@ add_qt_resource(qtquickcontrols2imaginestyleplugin "qmake_qtquickcontrols2imagin
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
# TARGETPATH = "QtQuick/Controls.2/Imagine"
-# _LOADED = "qml_plugin"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-imagine)"
set(qml_files
"ApplicationWindow.qml"
@@ -116,10 +116,6 @@ set(qml_files
"Tumbler.qml"
)
-set_source_files_properties(${qml_files} PROPERTIES
- QT_QML_SOURCE_INSTALL TRUE
-)
-
qt6_target_qml_files(qtquickcontrols2imaginestyleplugin
FILES
${qml_files}
diff --git a/src/imports/controls/imagine/CMakeLists.txt b/src/imports/controls/imagine/CMakeLists.txt
index 98661788..f0435255 100644
--- a/src/imports/controls/imagine/CMakeLists.txt
+++ b/src/imports/controls/imagine/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2imaginestyleplugin Plugin:
#####################################################################
-add_qml_module(qtquickcontrols2imaginestyleplugin
+qt_add_qml_module(qtquickcontrols2imaginestyleplugin
TARGET_PATH "QtQuick/Controls.2/Imagine"
URI "QtQuick.Controls.Imagine"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
@@ -52,7 +52,7 @@ set(qmake_qtquickcontrols2imaginestyle_resource_files
${resource_glob_1}
)
-add_qt_resource(qtquickcontrols2imaginestyleplugin "qmake_qtquickcontrols2imaginestyle"
+qt_add_resource(qtquickcontrols2imaginestyleplugin "qmake_qtquickcontrols2imaginestyle"
PREFIX
"qt-project.org/imports/QtQuick/Controls.2/Imagine"
FILES
@@ -65,7 +65,6 @@ add_qt_resource(qtquickcontrols2imaginestyleplugin "qmake_qtquickcontrols2imagin
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
# TARGETPATH = "QtQuick/Controls.2/Imagine"
-# _LOADED = "qml_plugin"
# _REQUIREMENTS = "qtConfig(quickcontrols2-imagine)"
set(qml_files
diff --git a/src/imports/controls/material/.prev_CMakeLists.txt b/src/imports/controls/material/.prev_CMakeLists.txt
index 3cf6d5d2..15fe3519 100644
--- a/src/imports/controls/material/.prev_CMakeLists.txt
+++ b/src/imports/controls/material/.prev_CMakeLists.txt
@@ -69,7 +69,7 @@ add_qt_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialsty
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
# TARGETPATH = "QtQuick/Controls.2/Material"
-# _LOADED = "qml_plugin"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-material)"
set(qml_files
"ApplicationWindow.qml"
@@ -130,10 +130,6 @@ set(qml_files
"Tumbler.qml"
)
-set_source_files_properties(${qml_files} PROPERTIES
- QT_QML_SOURCE_INSTALL TRUE
-)
-
qt6_target_qml_files(qtquickcontrols2materialstyleplugin
FILES
${qml_files}
diff --git a/src/imports/controls/material/CMakeLists.txt b/src/imports/controls/material/CMakeLists.txt
index ae5ffe83..c6a2be63 100644
--- a/src/imports/controls/material/CMakeLists.txt
+++ b/src/imports/controls/material/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2materialstyleplugin Plugin:
#####################################################################
-add_qml_module(qtquickcontrols2materialstyleplugin
+qt_add_qml_module(qtquickcontrols2materialstyleplugin
TARGET_PATH "QtQuick/Controls.2/Material"
URI "QtQuick.Controls.Material"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
@@ -56,7 +56,7 @@ set(qtquickcontrols2materialstyleplugin_resource_files
"shaders/RectangularGlow.frag"
)
-add_qt_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
+qt_add_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
PREFIX
"/qt-project.org/imports/QtQuick/Controls.2/Material"
FILES
@@ -69,7 +69,6 @@ add_qt_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialsty
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
# TARGETPATH = "QtQuick/Controls.2/Material"
-# _LOADED = "qml_plugin"
# _REQUIREMENTS = "qtConfig(quickcontrols2-material)"
set(qml_files
diff --git a/src/imports/controls/universal/.prev_CMakeLists.txt b/src/imports/controls/universal/.prev_CMakeLists.txt
index c14876da..f78b6e49 100644
--- a/src/imports/controls/universal/.prev_CMakeLists.txt
+++ b/src/imports/controls/universal/.prev_CMakeLists.txt
@@ -69,7 +69,7 @@ add_qt_resource(qtquickcontrols2universalstyleplugin "qtquickcontrols2universals
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
# TARGETPATH = "QtQuick/Controls.2/Universal"
-# _LOADED = "qml_plugin"
+# _REQUIREMENTS = "qtConfig(quickcontrols2-universal)"
set(qml_files
"ApplicationWindow.qml"
@@ -124,10 +124,6 @@ set(qml_files
"Tumbler.qml"
)
-set_source_files_properties(${qml_files} PROPERTIES
- QT_QML_SOURCE_INSTALL TRUE
-)
-
qt6_target_qml_files(qtquickcontrols2universalstyleplugin
FILES
${qml_files}
diff --git a/src/imports/controls/universal/CMakeLists.txt b/src/imports/controls/universal/CMakeLists.txt
index 3f4ef34b..802e40f2 100644
--- a/src/imports/controls/universal/CMakeLists.txt
+++ b/src/imports/controls/universal/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2universalstyleplugin Plugin:
#####################################################################
-add_qml_module(qtquickcontrols2universalstyleplugin
+qt_add_qml_module(qtquickcontrols2universalstyleplugin
TARGET_PATH "QtQuick/Controls.2/Universal"
URI "QtQuick.Controls.Universal"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
@@ -56,7 +56,7 @@ set(qtquickcontrols2universalstyleplugin_resource_files
"images/rightarrow@4x.png"
)
-add_qt_resource(qtquickcontrols2universalstyleplugin "qtquickcontrols2universalstyleplugin"
+qt_add_resource(qtquickcontrols2universalstyleplugin "qtquickcontrols2universalstyleplugin"
PREFIX
"/qt-project.org/imports/QtQuick/Controls.2/Universal"
FILES
@@ -69,7 +69,6 @@ add_qt_resource(qtquickcontrols2universalstyleplugin "qtquickcontrols2universals
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# OTHER_FILES = "qmldir" "$$QML_FILES"
# TARGETPATH = "QtQuick/Controls.2/Universal"
-# _LOADED = "qml_plugin"
# _REQUIREMENTS = "qtConfig(quickcontrols2-universal)"
set(qml_files