aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/templates/.prev_CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-10-06 10:24:53 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-10-12 21:42:42 +0200
commit716619e43edaaaa4daff96be28760cc8cfcfcf66 (patch)
tree55137a2cabb985cbf2835c46e4cc05a3d58605cc /src/imports/templates/.prev_CMakeLists.txt
parent4da42d87707779509f44fe4893636f20ec913f79 (diff)
Have templates depend on QtQuick
Templates defines a number of C++-based QML types, most of those are derived from QQuickItem. Therefore, it actually needs QtQuick although it never explicitly imports QtQuick. In order for tools to figure that out, declare the QtQuick dependency in the qmldir file. Task-number: QTBUG-87164 Change-Id: I982b4ee57102ac62b0ee6e8559e34c5e203a7a0f Reviewed-by: Maximilian Goldstein <max.goldstein@qt.io> Reviewed-by: Mitch Curtis <mitch.curtis@qt.io>
Diffstat (limited to 'src/imports/templates/.prev_CMakeLists.txt')
-rw-r--r--src/imports/templates/.prev_CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/imports/templates/.prev_CMakeLists.txt b/src/imports/templates/.prev_CMakeLists.txt
index 7799ab66..cd6a68f9 100644
--- a/src/imports/templates/.prev_CMakeLists.txt
+++ b/src/imports/templates/.prev_CMakeLists.txt
@@ -8,6 +8,8 @@ qt_internal_add_qml_module(qtquicktemplates2plugin
URI "QtQuick.Templates"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickTemplates2Plugin
+ DEPENDENCIES
+ QtQuick/auto
SKIP_TYPE_REGISTRATION
SOURCES
qtquicktemplates2plugin.cpp