aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-12-09 17:35:46 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-12-10 12:59:17 +0100
commitc094aa6f1bf884be5fd931587c7588a5a30f5503 (patch)
treeb7c8dac2e36ebaf29190a7bbdd6a834ae576d784 /src/imports
parent4f37ab46c61319b9288c6464fd2c57d8fbbeb4a7 (diff)
CMake: Fix nativestyle qmldir dependencies
pro2cmake chokes on converting the nativestyle project, because it expects to find a second argument after the depends clause. Add an 'auto', and regenerate the project. Amends a3253c37903e95706f011bc03093160236b57bdc Pick-to: 6.0 Task-number: QTBUG-88492 Change-Id: I4c9114780e17f5bc21a43511e75207eaef5e7550 Reviewed-by: Richard Moe Gustavsen <richard.gustavsen@qt.io> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/nativestyle/CMakeLists.txt4
-rw-r--r--src/imports/nativestyle/qmldir4
2 files changed, 4 insertions, 4 deletions
diff --git a/src/imports/nativestyle/CMakeLists.txt b/src/imports/nativestyle/CMakeLists.txt
index f3a66202..942e0fc3 100644
--- a/src/imports/nativestyle/CMakeLists.txt
+++ b/src/imports/nativestyle/CMakeLists.txt
@@ -9,8 +9,8 @@ qt_internal_add_qml_module(qtquickcontrols2nativestyleplugin
VERSION "6.0"
CLASSNAME QtQuickControls2NativeStylePlugin
DEPENDENCIES
- QtQuick.Controls
- QtQuick.Layouts
+ QtQuick.Controls/auto
+ QtQuick.Layouts/auto
PAST_MAJOR_VERSIONS 2
GENERATE_QMLTYPES
INSTALL_QMLTYPES
diff --git a/src/imports/nativestyle/qmldir b/src/imports/nativestyle/qmldir
index 06914fd3..4149cce2 100644
--- a/src/imports/nativestyle/qmldir
+++ b/src/imports/nativestyle/qmldir
@@ -1,8 +1,8 @@
module QtQuick.NativeStyle
plugin qtquickcontrols2nativestyleplugin
classname QtQuickControls2NativeStylePlugin
-depends QtQuick.Controls
-depends QtQuick.Layouts
+depends QtQuick.Controls auto
+depends QtQuick.Layouts auto
DefaultButton 2.0 controls/DefaultButton.qml
DefaultButton 6.0 controls/DefaultButton.qml