aboutsummaryrefslogtreecommitdiffstats
path: root/src/quickcontrols2/fusion/impl/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@qt.io>2021-05-31 16:40:54 +1000
committerUlf Hermann <ulf.hermann@qt.io>2021-06-05 12:52:00 +0200
commit5e8feb64d6a3cf50360c066e4595e41021bd0f9c (patch)
treec7901024f6c082dab14c97d109853ab5a64db1e1 /src/quickcontrols2/fusion/impl/CMakeLists.txt
parent284936db8327f030473c0533041ee850f5369bdd (diff)
Update to latest qml CMake API
The new qml CMake API places a closer relationship between the backing target and the plugin target. Both are typically created together and they share a lot of common details. Instead of creating them in different parts of the source tree, they are now specified together. The src/imports area has effectively been absorbed into the other corresponding subdirectories below src with this change. Task-number: QTBUG-91621 Change-Id: I9bd32e9eb78c198ccc9db04e2829303cac323502 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/quickcontrols2/fusion/impl/CMakeLists.txt')
-rw-r--r--src/quickcontrols2/fusion/impl/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/quickcontrols2/fusion/impl/CMakeLists.txt b/src/quickcontrols2/fusion/impl/CMakeLists.txt
new file mode 100644
index 00000000..c107ae75
--- /dev/null
+++ b/src/quickcontrols2/fusion/impl/CMakeLists.txt
@@ -0,0 +1,44 @@
+#####################################################################
+## qtquickcontrols2fusionstyleimplplugin Plugin:
+#####################################################################
+
+set(qml_files
+ "ButtonPanel.qml"
+ "CheckIndicator.qml"
+ "RadioIndicator.qml"
+ "SliderGroove.qml"
+ "SliderHandle.qml"
+ "SwitchIndicator.qml"
+)
+set_source_files_properties(${qml_files} PROPERTIES
+ QT_QML_SOURCE_VERSION "2.3"
+)
+
+qt_internal_add_qml_module(qtquickcontrols2fusionstyleimplplugin
+ URI "QtQuick.Controls.Fusion.impl"
+ VERSION "${PROJECT_VERSION}"
+ CLASS_NAME QtQuickControls2FusionStyleImplPlugin
+ PLUGIN_TARGET qtquickcontrols2fusionstyleimplplugin
+ NO_PLUGIN_OPTIONAL
+ SOURCES
+ qquickfusionbusyindicator.cpp qquickfusionbusyindicator_p.h
+ qquickfusiondial.cpp qquickfusiondial_p.h
+ qquickfusionknob.cpp qquickfusionknob_p.h
+ QML_FILES
+ ${qml_files}
+ DEFINES
+ QT_NO_CAST_FROM_ASCII
+ QT_NO_CAST_TO_ASCII
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::QmlPrivate
+ Qt::QuickControls2ImplPrivate
+ Qt::QuickPrivate
+ Qt::QuickTemplates2Private
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)