aboutsummaryrefslogtreecommitdiffstats
path: root/src/quickcontrols2impl/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@qt.io>2021-05-31 16:40:54 +1000
committerUlf Hermann <ulf.hermann@qt.io>2021-06-05 12:52:00 +0200
commit5e8feb64d6a3cf50360c066e4595e41021bd0f9c (patch)
treec7901024f6c082dab14c97d109853ab5a64db1e1 /src/quickcontrols2impl/CMakeLists.txt
parent284936db8327f030473c0533041ee850f5369bdd (diff)
Update to latest qml CMake API
The new qml CMake API places a closer relationship between the backing target and the plugin target. Both are typically created together and they share a lot of common details. Instead of creating them in different parts of the source tree, they are now specified together. The src/imports area has effectively been absorbed into the other corresponding subdirectories below src with this change. Task-number: QTBUG-91621 Change-Id: I9bd32e9eb78c198ccc9db04e2829303cac323502 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/quickcontrols2impl/CMakeLists.txt')
-rw-r--r--src/quickcontrols2impl/CMakeLists.txt30
1 files changed, 7 insertions, 23 deletions
diff --git a/src/quickcontrols2impl/CMakeLists.txt b/src/quickcontrols2impl/CMakeLists.txt
index 86e3b84a..048938a8 100644
--- a/src/quickcontrols2impl/CMakeLists.txt
+++ b/src/quickcontrols2impl/CMakeLists.txt
@@ -1,10 +1,14 @@
-# Generated from quickcontrols2impl.pro.
-
#####################################################################
## QuickControls2Impl Module:
#####################################################################
-qt_internal_add_module(QuickControls2Impl
+qt_internal_add_qml_module(QuickControls2Impl
+ URI "QtQuick.Controls.impl"
+ VERSION "${PROJECT_VERSION}"
+ CLASS_NAME QtQuickControls2ImplPlugin
+ DEPENDENCIES
+ QtQuick/auto
+ PLUGIN_TARGET qtquickcontrols2implplugin
SOURCES
qquickanimatednode.cpp qquickanimatednode_p.h
qquickattachedobject.cpp qquickattachedobject_p.h
@@ -37,27 +41,7 @@ qt_internal_add_module(QuickControls2Impl
Qt::Quick
)
-#### Keys ignored in scope 1:.:.:quickcontrols2impl.pro:<TRUE>:
-# MODULE = "quickcontrols2impl"
-# QMLTYPES_FILENAME = "plugins.qmltypes"
-# QMLTYPES_INSTALL_DIR = "$$[QT_INSTALL_QML]/QtQuick/Controls/impl"
-# QML_IMPORT_NAME = "QtQuick.Controls.impl"
-# QML_IMPORT_VERSION = "$$QT_VERSION"
-
-## Scopes:
-#####################################################################
-
qt_internal_extend_target(QuickControls2Impl CONDITION QT_FEATURE_quick_listview AND QT_FEATURE_quick_pathview
SOURCES
qquicktumblerview.cpp qquicktumblerview_p.h
)
-
-set_target_properties(QuickControls2Impl PROPERTIES
- QT_QML_MODULE_INSTALL_QMLTYPES TRUE
- QT_QML_MODULE_VERSION ${PROJECT_VERSION}
- QT_QML_MODULE_URI QtQuick.Controls.impl
- QT_QMLTYPES_FILENAME plugins.qmltypes
- QT_QML_MODULE_INSTALL_DIR "${INSTALL_QMLDIR}/QtQuick/Controls/impl"
-)
-
-qt6_qml_type_registration(QuickControls2Impl)