aboutsummaryrefslogtreecommitdiffstats
path: root/src/quickcontrols2impl/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-07-06 18:24:11 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-07-09 10:58:22 +0200
commit9c30798a439e6a87b574472aca7a4e15107c6221 (patch)
tree729345d5b4f1e4c70cdc93effda4a49c5017d9bf /src/quickcontrols2impl/CMakeLists.txt
parent8f9ed4a4650cc0560b09d4c251d89e66265021d9 (diff)
CMake: Don't give plugins PUBLIC usage requirements
The pro2cmake.py conversion script faithfully reproduced the .pro files for the plugins, which specified the libraries as public. But in CMake, the implications of this are that public usage requirements should then be propagated to consumers. We don't expect any consumers, since a plugin is created as a MODULE library in CMake, so for Windows we don't even have an import library to link with. The only exception to this is for static builds where plugins are created as STATIC libraries instead, but only in certain controlled situations do we then link to plugins. Even then, usage requirements are not expected to propagate to the consumers, so these relationships should always be specified as private. As a drive-by fix, remove Qt::Foo dependencies that are already implied by Qt::FooPrivate. Pick-to: 6.2 Task-number: QTBUG-90819 Change-Id: I3f33766612367520e09e599f03ac06d43613aa81 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/quickcontrols2impl/CMakeLists.txt')
-rw-r--r--src/quickcontrols2impl/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/quickcontrols2impl/CMakeLists.txt b/src/quickcontrols2impl/CMakeLists.txt
index 048938a8..dcad4d42 100644
--- a/src/quickcontrols2impl/CMakeLists.txt
+++ b/src/quickcontrols2impl/CMakeLists.txt
@@ -35,10 +35,6 @@ qt_internal_add_qml_module(QuickControls2Impl
Qt::QmlPrivate
Qt::QuickPrivate
Qt::QuickTemplates2Private
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
- Qt::Quick
)
qt_internal_extend_target(QuickControls2Impl CONDITION QT_FEATURE_quick_listview AND QT_FEATURE_quick_pathview