aboutsummaryrefslogtreecommitdiffstats
path: root/src/quicktemplates2/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-09 16:41:38 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-17 14:39:47 +0000
commite558d0794b4b22e35ce217818dd96d1e45957b10 (patch)
tree87da2e2458f1af39876be2dd4c3864bd46e7051a /src/quicktemplates2/CMakeLists.txt
parentf52b95a96cc8f36f766635f9ddb6c95fa6b3c934 (diff)
CMake: Regenerate projectswip/cmake
Change-Id: Ifd6b2289de6465a010f5f2a32789221767b4d5be Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/quicktemplates2/CMakeLists.txt')
-rw-r--r--src/quicktemplates2/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/quicktemplates2/CMakeLists.txt b/src/quicktemplates2/CMakeLists.txt
index 98e39274..df8c6071 100644
--- a/src/quicktemplates2/CMakeLists.txt
+++ b/src/quicktemplates2/CMakeLists.txt
@@ -37,6 +37,8 @@ qt_add_module(QuickTemplates2
qquickframe.cpp qquickframe_p.h
qquickframe_p_p.h
qquickgroupbox.cpp qquickgroupbox_p.h
+ qquickheaderview.cpp qquickheaderview_p.h
+ qquickheaderview_p_p.h
qquickicon.cpp qquickicon_p.h
qquickitemdelegate.cpp qquickitemdelegate_p.h
qquickitemdelegate_p_p.h
@@ -138,6 +140,8 @@ qt_extend_target(QuickTemplates2 CONDITION TARGET Qt::QmlModels
Qt::QmlModelsPrivate
PUBLIC_LIBRARIES
Qt::QmlModels
+ PRIVATE_MODULE_INTERFACE
+ Qt::QmlModelsPrivate
)
qt_extend_target(QuickTemplates2 CONDITION QT_FEATURE_quick_listview AND QT_FEATURE_quick_pathview