aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/platform/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-17 15:41:53 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-17 15:55:25 +0100
commit82fbcf2846e20fc207b005221bd027fbfc7d4eee (patch)
tree8b2213859ecdc2a6a0e49fe6ea240e01db89f2b9 /tests/auto/platform/CMakeLists.txt
parent7da5842647f75fd990f69f400f75d9b090e39306 (diff)
parente558d0794b4b22e35ce217818dd96d1e45957b10 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Conflicts: dependencies.yaml Change-Id: Ie7f9fa70c59e9e5b890f9715d35a098c360dd869
Diffstat (limited to 'tests/auto/platform/CMakeLists.txt')
-rw-r--r--tests/auto/platform/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/auto/platform/CMakeLists.txt b/tests/auto/platform/CMakeLists.txt
new file mode 100644
index 00000000..ec4e54ee
--- /dev/null
+++ b/tests/auto/platform/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from platform.pro.
+
+#####################################################################
+## tst_platform Test:
+#####################################################################
+
+# Collect test data
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/data/tst_*)
+list(APPEND test_data ${test_data_glob})
+
+qt_add_test(tst_platform
+ GUI
+ QMLTEST
+ SOURCES
+ tst_platform.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ TESTDATA ${test_data}
+)
+
+#### Keys ignored in scope 1:.:.:platform.pro:<TRUE>:
+# OTHER_FILES = "$$PWD/data/*.qml"
+# TEMPLATE = "app"