aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index 05dcd0a7..00000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
-# Generated from qtquickcontrols2.pro.
-
-cmake_minimum_required(VERSION 3.15.0)
-
-include(.cmake.conf)
-project(QtQuickControls2
- VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt QuickControls2 Libraries"
- HOMEPAGE_URL "https://qt.io/"
- LANGUAGES CXX C
-)
-
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network Qml Quick QmlTools # special case
- OPTIONAL_COMPONENTS QuickTest # special case
-)
-if(NOT TARGET Qt::Quick)
- message(NOTICE "Skipping the build as the condition \"TARGET Qt::Quick\" is not met.")
- return()
-endif()
-qt_build_repo()