aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/gallery/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quickcontrols2/gallery/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/gallery/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/examples/quickcontrols2/gallery/CMakeLists.txt b/examples/quickcontrols2/gallery/CMakeLists.txt
index a175afa9..d4c9df04 100644
--- a/examples/quickcontrols2/gallery/CMakeLists.txt
+++ b/examples/quickcontrols2/gallery/CMakeLists.txt
@@ -1,7 +1,7 @@
# Generated from gallery.pro.
cmake_minimum_required(VERSION 3.14)
-project(gallery LANGUAGES CXX)
+project(gallery_controls2 LANGUAGES CXX) # special case
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -20,10 +20,10 @@ find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Quick)
find_package(Qt6 COMPONENTS QuickControls2)
-add_qt_gui_executable(gallery
+add_qt_gui_executable(gallery_controls2 # special case
gallery.cpp
)
-target_link_libraries(gallery PUBLIC
+target_link_libraries(gallery_controls2 PUBLIC # special case
Qt::Core
Qt::Gui
Qt::Quick
@@ -89,14 +89,14 @@ set(qmake_immediate_resource_files
"qtquickcontrols2.conf"
)
-qt6_add_resources(gallery "qmake_immediate"
+qt6_add_resources(gallery_controls2 "qmake_immediate" # special case
PREFIX
"/"
FILES
${qmake_immediate_resource_files}
)
-install(TARGETS gallery
+install(TARGETS gallery_controls2 # special case
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"