aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/gallery/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/quickcontrols2/gallery/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/gallery/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/quickcontrols2/gallery/CMakeLists.txt b/examples/quickcontrols2/gallery/CMakeLists.txt
index dc61edf0..06ddf333 100644
--- a/examples/quickcontrols2/gallery/CMakeLists.txt
+++ b/examples/quickcontrols2/gallery/CMakeLists.txt
@@ -23,6 +23,10 @@ find_package(Qt6 COMPONENTS QuickControls2)
qt_add_executable(gallery_controls2 # special case
gallery.cpp
)
+set_target_properties(gallery_controls2 PROPERTIES # special case
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(gallery_controls2 PUBLIC # special case
Qt::Core
Qt::Gui