aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controls/material/.prev_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/controls/material/.prev_CMakeLists.txt')
-rw-r--r--src/imports/controls/material/.prev_CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/imports/controls/material/.prev_CMakeLists.txt b/src/imports/controls/material/.prev_CMakeLists.txt
index 3f82f1e4..2547a0f8 100644
--- a/src/imports/controls/material/.prev_CMakeLists.txt
+++ b/src/imports/controls/material/.prev_CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquickcontrols2materialstyleplugin Plugin:
#####################################################################
-qt_add_qml_module(qtquickcontrols2materialstyleplugin
+qt_internal_add_qml_module(qtquickcontrols2materialstyleplugin
URI "QtQuick.Controls.Material"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickControls2MaterialStylePlugin
@@ -53,7 +53,7 @@ set(qtquickcontrols2materialstyleplugin_resource_files
"shaders/RectangularGlow.frag"
)
-qt_add_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
+qt_internal_add_resource(qtquickcontrols2materialstyleplugin "qtquickcontrols2materialstyleplugin"
PREFIX
"/qt-project.org/imports/QtQuick/Controls/Material"
FILES
@@ -99,6 +99,7 @@ set(qml_files
"RadioDelegate.qml"
"RangeSlider.qml"
"RoundButton.qml"
+ "ScrollView.qml"
"ScrollBar.qml"
"ScrollIndicator.qml"
"Slider.qml"
@@ -210,6 +211,9 @@ set_source_files_properties(RangeSlider.qml PROPERTIES
set_source_files_properties(RoundButton.qml PROPERTIES
QT_QML_SOURCE_VERSION "2.1;6.0"
)
+set_source_files_properties(ScrollView.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "2.0;6.0"
+)
set_source_files_properties(ScrollBar.qml PROPERTIES
QT_QML_SOURCE_VERSION "2.0;6.0"
)