aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/controlsimpl
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/controlsimpl')
-rw-r--r--src/imports/controlsimpl/.prev_CMakeLists.txt35
-rw-r--r--src/imports/controlsimpl/CMakeLists.txt35
-rw-r--r--src/imports/controlsimpl/controlsimpl.pro17
-rw-r--r--src/imports/controlsimpl/qmldir3
-rw-r--r--src/imports/controlsimpl/qtquickcontrols2implplugin.cpp59
5 files changed, 0 insertions, 149 deletions
diff --git a/src/imports/controlsimpl/.prev_CMakeLists.txt b/src/imports/controlsimpl/.prev_CMakeLists.txt
deleted file mode 100644
index 9d8049f5..00000000
--- a/src/imports/controlsimpl/.prev_CMakeLists.txt
+++ /dev/null
@@ -1,35 +0,0 @@
-# Generated from controlsimpl.pro.
-
-#####################################################################
-## qtquickcontrols2implplugin Plugin:
-#####################################################################
-
-qt_internal_add_qml_module(qtquickcontrols2implplugin
- URI "QtQuick.Controls.impl"
- VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QtQuickControls2ImplPlugin
- SKIP_TYPE_REGISTRATION
- SOURCES
- qtquickcontrols2implplugin.cpp
- DEFINES
- QT_NO_CAST_FROM_ASCII
- QT_NO_CAST_TO_ASCII
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::QmlPrivate
- Qt::QuickControls2ImplPrivate
- Qt::QuickControls2Private
- Qt::QuickPrivate
- Qt::QuickTemplates2Private
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
-)
-
-#### Keys ignored in scope 1:.:.:controlsimpl.pro:<TRUE>:
-# OTHER_FILES = "qmldir"
-# QML_IMPORT_VERSION = "$$QT_VERSION"
-# TARGETPATH = "QtQuick/Controls/impl"
diff --git a/src/imports/controlsimpl/CMakeLists.txt b/src/imports/controlsimpl/CMakeLists.txt
deleted file mode 100644
index 3ffc396c..00000000
--- a/src/imports/controlsimpl/CMakeLists.txt
+++ /dev/null
@@ -1,35 +0,0 @@
-# Generated from controlsimpl.pro.
-
-#####################################################################
-## qtquickcontrols2implplugin Plugin:
-#####################################################################
-
-qt_internal_add_qml_module(qtquickcontrols2implplugin
- URI "QtQuick.Controls.impl"
- VERSION "6.0" # special case
- CLASSNAME QtQuickControls2ImplPlugin
- SKIP_TYPE_REGISTRATION
- SOURCES
- qtquickcontrols2implplugin.cpp
- DEFINES
- QT_NO_CAST_FROM_ASCII
- QT_NO_CAST_TO_ASCII
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::QmlPrivate
- Qt::QuickControls2ImplPrivate
- Qt::QuickControls2Private
- Qt::QuickPrivate
- Qt::QuickTemplates2Private
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
-)
-
-#### Keys ignored in scope 1:.:.:controlsimpl.pro:<TRUE>:
-# OTHER_FILES = "qmldir"
-# QML_IMPORT_VERSION = "$$QT_VERSION"
-# TARGETPATH = "QtQuick/Controls/impl"
diff --git a/src/imports/controlsimpl/controlsimpl.pro b/src/imports/controlsimpl/controlsimpl.pro
deleted file mode 100644
index ed629ce9..00000000
--- a/src/imports/controlsimpl/controlsimpl.pro
+++ /dev/null
@@ -1,17 +0,0 @@
-TARGET = qtquickcontrols2implplugin
-TARGETPATH = QtQuick/Controls/impl
-QML_IMPORT_VERSION = $$QT_VERSION
-
-QT += qml quick
-QT_PRIVATE += core-private gui-private qml-private quick-private quicktemplates2-private quickcontrols2-private quickcontrols2impl-private
-
-DEFINES += QT_NO_CAST_TO_ASCII QT_NO_CAST_FROM_ASCII
-
-OTHER_FILES += \
- qmldir
-
-SOURCES += \
- $$PWD/qtquickcontrols2implplugin.cpp
-
-CONFIG += no_cxx_module
-load(qml_plugin)
diff --git a/src/imports/controlsimpl/qmldir b/src/imports/controlsimpl/qmldir
deleted file mode 100644
index 98eed8ae..00000000
--- a/src/imports/controlsimpl/qmldir
+++ /dev/null
@@ -1,3 +0,0 @@
-module QtQuick.Controls.impl
-plugin qtquickcontrols2implplugin
-classname QtQuickControls2ImplPlugin
diff --git a/src/imports/controlsimpl/qtquickcontrols2implplugin.cpp b/src/imports/controlsimpl/qtquickcontrols2implplugin.cpp
deleted file mode 100644
index d5f29f5c..00000000
--- a/src/imports/controlsimpl/qtquickcontrols2implplugin.cpp
+++ /dev/null
@@ -1,59 +0,0 @@
-/****************************************************************************
-**
-** Copyright (C) 2020 The Qt Company Ltd.
-** Contact: http://www.qt.io/licensing/
-**
-** This file is part of the Qt Quick Controls 2 module of the Qt Toolkit.
-**
-** $QT_BEGIN_LICENSE:LGPL3$
-** Commercial License Usage
-** Licensees holding valid commercial Qt licenses may use this file in
-** accordance with the commercial license agreement provided with the
-** Software or, alternatively, in accordance with the terms contained in
-** a written agreement between you and The Qt Company. For licensing terms
-** and conditions see http://www.qt.io/terms-conditions. For further
-** information use the contact form at http://www.qt.io/contact-us.
-**
-** GNU Lesser General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU Lesser
-** General Public License version 3 as published by the Free Software
-** Foundation and appearing in the file LICENSE.LGPLv3 included in the
-** packaging of this file. Please review the following information to
-** ensure the GNU Lesser General Public License version 3 requirements
-** will be met: https://www.gnu.org/licenses/lgpl.html.
-**
-** GNU General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU
-** General Public License version 2.0 or later as published by the Free
-** Software Foundation and appearing in the file LICENSE.GPL included in
-** the packaging of this file. Please review the following information to
-** ensure the GNU General Public License version 2.0 requirements will be
-** met: http://www.gnu.org/licenses/gpl-2.0.html.
-**
-** $QT_END_LICENSE$
-**
-****************************************************************************/
-
-#include <QtQml/qqmlextensionplugin.h>
-#include <QtQuickControls2Impl/private/qtquickcontrols2implglobal_p.h>
-
-QT_BEGIN_NAMESPACE
-
-class QtQuickControls2ImplPlugin : public QQmlEngineExtensionPlugin
-{
- Q_OBJECT
- Q_PLUGIN_METADATA(IID QQmlExtensionInterface_iid)
-
-public:
- QtQuickControls2ImplPlugin(QObject *parent = nullptr);
-};
-
-QtQuickControls2ImplPlugin::QtQuickControls2ImplPlugin(QObject *parent) : QQmlEngineExtensionPlugin(parent)
-{
- volatile auto registration = &qml_register_types_QtQuick_Controls_impl;
- Q_UNUSED(registration)
-}
-
-QT_END_NAMESPACE
-
-#include "qtquickcontrols2implplugin.moc"